不支持此服务器版本。目标服务器必须是 SQL Server 2000 或更高版本问题解决

数据库学习 专栏收录该内容
5 篇文章 0 订阅

    使用JDBC链接SQL Server2008时报错,出现"不支持此服务器版本。目标服务器必须是 SQL Server 2000 或更高版本问题解决"的异常提示,google了好久还是没有解决问题!

    有的说是JAR包不对(我用的是SQLSERVER05的JAR包),有的给出地址来下载最新的SQL SERVER为JDBC提供的JAR包(sqljdbc_2.0.1803.100_chs.exe),安装提示下载完成,放到classpath中,又提示不支持JDK1.6,很是郁闷。。。

    请教牛人,找到解决方法,原来使用SQLSERVER05的JAR包完全可以访问SQLSERVER08的数据库,出现错误的原因是因为JAR包,在我的classpath上有两个JAR包sqljdbc4.jar和sqljdbc.jar,就是因为"sqljdbc.jar"的原因使得无法访问SQLSERVER08数据库,将“sqljdbc.jar”删掉,只留sqljdbc4.jar就可以了!

    即解决方案:确保CLASSPATH中只有”sqljdbc4.jar“,不能包含"sqljdbc.jar".

 

  • 0
    点赞
  • 1
    评论
  • 0
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

©️2021 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值