pku2362 Square(又是TLE.....................)

/*

Square
Time Limit: 3000MS        Memory Limit: 65536K
Total Submissions: 7770        Accepted: 2774

Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".

Sample Input

3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5

Sample Output

yes
no
yes

Source
Waterloo local 2002.09.21*/








#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

class stick
{
public:
    int value;
    int sign;
};

bool cmp(stick a,stick b)
{
    return a.value > b.value;
}
bool flag = false;
int number = 0;

void solution(vector<stick> sticks,int st,int long1,int long2)
{

    if(st < sticks.size() && sticks[st].sign == 0)
    {
        if(long1 >= sticks[st].value)
        {
            long1 = long1 - sticks[st].value;
            sticks[st].sign = 1;
            if(long1 == 0)
            {
                number++;
                if(number == 4)
                {
                    flag = true;
                    return;
                }
                for(int ss = 0;ss < sticks.size();ss++)
                {
                    if(sticks[ss].sign == 0)
                    {
                        solution(sticks,ss,long2,long2);
                        break;
                    }
                }               
            }               
            else
            {
                solution(sticks,++st,long1,long2);
                sticks[st - 1].sign = 0;
                solution(sticks,st + 2,long2,long2);           
            }               
        }
        else
        {           
            solution(sticks,++st,long1,long2);                   
        }      
    }
    else if(st < sticks.size() && sticks[st].sign == 1)
    {
        solution(sticks,++st,long1,long2);
       
    }
}


int main(void)
{
    int testcase;
    cin>>testcase;
    int number2;   
    stick tmp;
    int sum = 0;
    while(testcase > 0)
    {
        testcase--;
        cin>>number2;
        vector<stick> sticks;
        for(int i = 0;i < number2;i++)
        {
            cin>>tmp.value;
            tmp.sign = 0;
            sum = sum + tmp.value;
            sticks.push_back(tmp);
        }
        sort(sticks.begin(),sticks.end(),cmp);
        if(sum % 4 == 0 && (*(sticks.begin())).value <= sum / 4)
        {
            solution(sticks,0,sum / 4,sum / 4);
       
        }
        if(flag == true)
        {
            cout<<"yes"<<endl;
        }
        else
        {
            cout<<"no"<<endl;
        }
        sum = 0;
        flag = false;
        number = 0;
    }
   
    return 0;
}
     
几乎和1011一样的题目。。貌似会简单的。。。。。。。。。不过居然又是TLE。。。。。。。。。。。。

该考虑考虑以后提交OJ的题目少用VECTOR少用STL了。。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值