1061. Dating (20)-PAT

Sherlock Holmes received a note with some strange strings: "Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm". It took him only a minute to figure out that those strange strings are actually referring to the coded time "Thursday 14:04" -- since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter 'D', representing the 4th day in a week; the second common character is the 5th capital letter 'E', representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is 's' at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.


Input Specification:


Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.


Output Specification:


For each test case, print the decoded time in one line, in the format "DAY HH:MM", where "DAY" is a 3-character abbreviation for the days in a week -- that is, "MON" for Monday, "TUE" for Tuesday, "WED" for Wednesday, "THU" for Thursday, "FRI" for Friday, "SAT" for Saturday, and "SUN" for Sunday. It is guaranteed that the result is unique for each case.


Sample Input:
3485djDkxh4hhGE 
2984akDfkkkkggEdsb 
s&hgsfdk 
d&Hyscvnm
Sample Output:

THU 14:04

推荐指数:

来源:http://pat.zju.edu.cn/contests/pat-a-practise/1061

注意题目的意思。

week 大写字母的A-G

hh 0-9 A-N

mm 位置

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<iostream>
using namespace std;

const int N=80;
char w[7][4]={{"MON"},{"TUE"},{"WED"},{"THU"},{"FRI"},{"SAT"},{"SUN"}};
int main()
{
	char s1[N],s2[N],s3[N],s4[N];
	scanf("%s%s%s%s",s1,s2,s3,s4);
	int i=0;
	int week,hh,mm;
	while(i<strlen(s1)&&i<strlen(s2)){
		if(s1[i]==s2[i]&&s1[i]>='A'&&s1[i]<='G'){
			week=s1[i]-'A';
			break;
		}
		i++;
	}
	i++;
	while(i<strlen(s1)&&i<strlen(s2)){
		if(s1[i]==s2[i]&& ((s1[i]>='A'&&s1[i]<='N')||(s1[i]>='0'&&s1[i]<='9'))){
			if((s1[i]>='A'&&s1[i]<='N'))
				hh=s1[i]-'A'+10;
			else if(s1[i]>='0'&&s1[i]<='9')
				hh=s1[i]-'0';
			break;
		}
		i++;
	}
	i=0;
	while(i<strlen(s3)&&i<strlen(s4)){
		if(s3[i]==s4[i]&&((s3[i]>='A'&&s3[i]<='Z')||(s3[i]>='a'&&s3[i]<='z'))){
			mm=i;
			break;
		}
		i++;
	}
	printf("%s %02d:%02d\n",w[week],hh,mm);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值