1059. Prime Factors (25)-PAT

1059. Prime Factors (25)

时间限制
50 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
HE, Qinming

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1* p2^k2 *…*pm^km.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1 * p2^k2 *…*pm^km, where pi's are prime factors of N in increasing order, and the exponent ki is the number of pi -- hence when there is only one pi, ki is 1 and must NOT be printed out.

Sample Input:
97532468
Sample Output:
97532468=2^2*11*17*101*1291
推荐指数:※
来源:http://pat.zju.edu.cn/contests/pat-a-practise/1059
这道题目主要是分解质因子。
1.考虑1的情况。
#include<iostream>
#include<string.h>
#include<math.h>
using namespace std;
bool is_prime(long n){
	long i,tmp;
	tmp=sqrt(n)+1;
	for(i=3;i<=tmp;i++){
		if(n%i==0)
			return false;
	}
	return true;
}
int main()
{
	long n,i,tmp,k;
	cin>>n;
	cout<<n<<"=";
	if(n==1){
		cout<<1;
		return 0;
	}
	tmp=n;
	for(i=2;i<=tmp;i++){
		k=0;
		if(is_prime(i)==true){
			while(n%i==0){
				k++;
				n=n/i;
			}
		}
		if(k>1){
			cout<<i<<"^"<<k;
		}
		else if(k==1){
			cout<<i;
		}
		if(n!=1&k>=1)
			cout<<"*";
		else if(n==1)
			break;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值