POJ 3321 Apple Tree 树状数组

Apple Tree
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 21839 Accepted: 6619

Description

There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 toN and the root is always numbered by 1. Apples will grow on the forks and two apple won't grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means forku and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
"C x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
"Q x" which means an inquiry for the number of apples in the sub-tree above the forkx, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2

Source

POJ Monthly--2007.08.05, Huang, Jinsong
ACcode:
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#define maxn 100000+5
using namespace std;
struct node1{
    int next;
    int tail;
}edge[maxn];
struct node2{
    int r,l;
}apple[maxn];
int s[maxn],cnt,c[maxn],a[maxn];
void dfs(int u){///从节点u出发,计算每个节点为根的子树区间[apple[].l,apple[].r]
    apple[u].l=cnt;
    for(int i=s[u];i!=-1;i=edge[i].next)
        dfs(edge[i].tail);
    apple[u].r=cnt++;
}
inline int lowbit(int x){
    return x&(-x);
}
void change(int x){
    if(a[x])
        for(int i=x;i<cnt;i+=lowbit(i))
            c[i]++;
    else
        for(int i=x;i<cnt;i+=lowbit(i))
            c[i]--;
}
int sum(int x){
    int i,res=0;
    for(i=x;i>0;i-=lowbit(i)){
        res+=c[i];
    }
    return res;
}
int main(){
    int n,m,t1,t2,t,i;
    char str[3];
    scanf("%d",&n);
    memset(s,-1,sizeof(s[0])*(n+1));
    memset(c,0,sizeof(c[0])*(n+1));
    memset(apple,0,sizeof(apple[0])*(n+1));
    for(i=0;i<n-1;++i){
        scanf("%d%d",&t1,&t2);
        edge[i].tail=t2;
        edge[i].next=s[t1];
        s[t1]=i;
    }
    cnt=1;
    dfs(1);
    scanf("%d",&m);
    for(i=1;i<=n;++i){
        a[i]=1;
        change(i);
    }
    while(m--){
        scanf("%s%d",&str,&t);
        if(str[0]=='Q')
            printf("%d\n",sum(apple[t].r)-sum(apple[t].l-1));
        else{
            a[apple[t].r]=(a[apple[t].r]+1)%2;///0--->1  1---->0;
            change(apple[t].r);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值