A1053. Path of Equal Weight (30)


Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. Theweight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.


Figure 1

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1, A2, ..., An} is said to begreater than sequence {B1, B2, ..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bi for i=1, ... k, and Ak+1 > Bk+1.

Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
 
 
因为这个题不只是涉及节点数,还有权重,要用struct,而且要注意,写DFS时可以简便一些,原有的depth可以用sum和替换,只要sum超过s就不需要遍历了,这一点比depth减少遍历很多元素。
 
 
因为输出是按权重大小排的,所以莫不如在输入后将结点的顺序按权重大下排一下,这样输出也是按大小顺序输出。给我的启发是,DFS排序市按过程的,与存储的顺序没有关系,所以存储的可以大胆改动,只要父子关系保持,和输入顺序没有关系。
代码如下:
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<vector>
#include<cmath>
using namespace std;

const int maxn=110;
int n,m,s;

struct node{
	int weight;
	vector<int> child;
}node[maxn];

bool cmp(int a,int b)
{
	return node[a].weight>node[b].weight;
}
int num=0;
int path[maxn]={0};//记录路径
void DFS(int index,int numNode,int sum)
{
	//index,当前访问结点,numNode,当前path路径上结点个数,sum当前结点权和。
	if(sum>s) return;
	if(sum==s)
	{
		if(node[index].child.size()!=0)
		return; //权值够,没到叶子点,返回	
		for(int j=0;j<numNode;j++)
		{
		printf("%d",node[path[j]].weight);
		if(j!=numNode-1)
			printf(" ");
		}
		printf("\n");	
		return;
	}
	for(int i=0;i<node[index].child.size();i++)
	{
		int child=node[index].child[i];
		path[numNode]=child;
		DFS(node[index].child[i],numNode+1,sum+node[node[index].child[i]].weight);
	}

}

int main()
{
	//freopen("data.in","r",stdin);
	scanf("%d %d %d",&n,&m,&s);
	for(int i=0;i<n;i++)
		scanf("%d",&node[i].weight);
	int id,k,temp;
	for(int j=0;j<m;j++)
	{
		scanf("%d %d",&id,&k);
		for(int l=0;l<k;l++)
		{
		scanf("%d",&temp);
		node[id].child.push_back(temp);
		}
		sort(node[id].child.begin(),node[id].child.end(),cmp);
	}

	path[0]=0;
	DFS(0,1,node[0].weight);
	
	return 0;
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值