HDU-4352 XHXJ's LIS

#define xhxj (Xin Hang senior sister(学姐))
If you do not know xhxj, then carefully reading the entire description is very important.
As the strongest fighting force in UESTC, xhxj grew up in Jintang, a border town of Chengdu.
Like many god cattles, xhxj has a legendary life:
2010.04, had not yet begun to learn the algorithm, xhxj won the second prize in the university contest. And in this fall, xhxj got one gold medal and one silver medal of regional contest. In the next year’s summer, xhxj was invited to Beijing to attend the astar onsite. A few months later, xhxj got two gold medals and was also qualified for world’s final. However, xhxj was defeated by zhymaoiing in the competition that determined who would go to the world’s final(there is only one team for every university to send to the world’s final) .Now, xhxj is much more stronger than ever,and she will go to the dreaming country to compete in TCO final.
As you see, xhxj always keeps a short hair(reasons unknown), so she looks like a boy( I will not tell you she is actually a lovely girl), wearing yellow T-shirt. When she is not talking, her round face feels very lovely, attracting others to touch her face gently。Unlike God Luo’s, another UESTC god cattle who has cool and noble charm, xhxj is quite approachable, lively, clever. On the other hand,xhxj is very sensitive to the beautiful properties, “this problem has a very good properties”,she always said that after ACing a very hard problem. She often helps in finding solutions, even though she is not good at the problems of that type.
Xhxj loves many games such as,Dota, ocg, mahjong, Starcraft 2, Diablo 3.etc,if you can beat her in any game above, you will get her admire and become a god cattle. She is very concerned with her younger schoolfellows, if she saw someone on a DOTA platform, she would say: “Why do not you go to improve your programming skill”. When she receives sincere compliments from others, she would say modestly: "Please don’t flatter at me.(Please don’t black)."As she will graduate after no more than one year, xhxj also wants to fall in love. However, the man in her dreams has not yet appeared, so she now prefers girls.
Another hobby of xhxj is yy(speculation) some magical problems to discover the special properties. For example, when she see a number, she would think whether the digits of a number are strictly increasing. If you consider the number as a string and can get a longest strictly increasing subsequence the length of which is equal to k, the power of this number is k… It is very simple to determine a single number’s power, but is it also easy to solve this problem with the numbers within an interval? xhxj has a little tired,she want a god cattle to help her solve this problem,the problem is: Determine how many numbers have the power value k in [L,R] in O(1)time.
For the first one to solve this problem,xhxj will upgrade 20 favorability rate。

Input
First a integer T(T<=10000),then T lines follow, every line has three positive integer L,R,K.( 0<L<=R<2^63-1 and 1<=K<=10).

Output
For each query, print “Case #t: ans” in a line, in which t is the number of the test case starting from 1 and ans is the answer.

Sample Input
1
123 321 2

Sample Output
Case #1: 139

题意:
求[L,R]区间最长递增子序列为k的数有多少个
例如 L=10,R=20,K=2;答案为8个12 13 14 15 16 17 18 19
题意很好理解,接下来我们就来讨论怎么解决这个问题
第一步我们想怎么处理这些数:最好的办法当然是二进制了,由于本题是严格递增的LIS,所以LIS最长为9
第二步确定状态 dp[len][state][k]:len表示当前位,state表示状态压缩,k表示LIS长度
我们可以通过dfs枚举所有的数
刚开始我们的state为 0 0 0 0 0 0 0 0 0 0
我们假设一个中间过程,例如我们枚举到157
len=3 i=1 此刻state会更新为 0 0 0 0 0 0 0 0 1 0
len=2 i=5 此刻state会更新为 0 0 0 0 1 0 0 0 1 0
len=1 i=7 此刻state会更新为 0 0 1 0 1 0 0 0 1 0
我们通过计算state中1的数量就可以算出LIS

讲到这可能还有很多同学不是很懂更新LIS的过程,如果有的同学对O(nlogn)复杂度求LIS不清楚的话,我们必须要弄清楚这个才能继续,这里推荐本人的一篇博客,上面贴了两种复杂度求LIS的方法 https://blog.csdn.net/zt2650693774/article/details/95729768

我们先看一下更新LIS的这段代码

int update(int s,int x){
	for(int i=x;i<=9;i++){
		//如果s比(1<<x)大的,就把s二进制的第i位置为0,第x位置为1 
		if(s&(1<<i)) return (s^(1<<i))|(1<<x);  
	}
	return s|(1<<x); //如果s比(1<<x)小,就把第x位置为1 
}

s表示之前的状态state x表示当前的这个数
例如我们要求13527的LIS,假设已经更新完了5,准备更新2
此时state为 0 0 0 0 1 0 1 0 1 0
很明显2要比5小,由于我们已经会了O(nlogn)求LIS的做法,我就直接讲了
此刻我们就要更新比第二位大的最近那个数,很明显我们要把第三位置为0,第二位置为1,更新后state为 0 0 0 0 1 0 0 1 1 0
我们继续,现在要更新7了,因为此刻state最高位为5,所以我们可以直接将第七位更新为1,更新完后state变为 0 0 1 0 1 0 0 1 1 0,state此刻的LIS即为1的数量

下面贴出AC源码

/*
	HDU-4352 XHXJ's LIS 
	数位DP dp[len][state][k]表示当前位为len,状态为state时,lis为k时的数字有多少个 
*/
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
ll k,dp[20][1<<10][11],digit[20];
int update(int s,int x){
	for(int i=x;i<=9;i++){
		//如果s比(1<<x)大的,就把s二进制的第i位置为0,第x位置为1 
		if(s&(1<<i)) return (s^(1<<i))|(1<<x);  
	}
	return s|(1<<x); //如果s比(1<<x)小,就把第x位置为1 
}
int getlis(ll x){ //求lis,也就是x的二进制中有多少个1 
	int res=0;
	for(int i=x;i;i>>=1) if(i&1) res++;
	return res;
}
ll dfs(int len,int state,bool fp){ 
	if(!len) return getlis(state)==k;  
	if(len && getlis(state)>k) return 0; //如果当前lis>k,就不需要继续走了,直接置为0 
	if(!fp && ~dp[len][state][k]) return dp[len][state][k];
	ll res=0; int fpmax=fp?digit[len]:9;
	for(int i=0;i<=fpmax;i++){
		//如果state=0&&i=0就不用更新了,因为012的lis为2不为3 
		res+=dfs(len-1,(state|i)?update(state,i):0,fp&&i==fpmax);
	}
	if(!fp) dp[len][state][k]=res;
	return res;
}
ll cal(ll x){
	int len=0;
	while(x){
		digit[++len]=x%10;
		x/=10;
	}
	return dfs(len,0,true);
}
int main(){
	int t,cas=0; cin>>t;
	memset(dp,-1,sizeof(dp));
	while(t--){
		ll l,r; cin>>l>>r>>k;
		cout<<"Case #"<<++cas<<": "<<cal(r)-cal(l-1)<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值