foj 1303

Problem Description

A calendar is a system for measuring time, from hours and minutes, to
months and days, and finally to years and centuries. The terms of
hour, day, month, year and century are all units of time measurements
of a calendar system.

According to the Gregorian calendar, which is the civil calendar in
use today, years evenly divisible by 4 are leap years, with the
exception of centurial years that are not evenly divisible by 400.
Therefore, the years 1700, 1800, 1900 and 2100 are not leap years, but
1600, 2000, and 2400 are leap years.

Given the number of days that have elapsed since January 1, 2000 A.D,
your mission is to find the date and the day of the week.

Input

The input consists of lines each containing a positive integer, which
is the number of days that have elapsed since January 1, 2000 A.D. The
last line contains an integer -1, which should not be processed. You
may assume that the resulting date won’t be after the year 9999.

Output

For each test case, output one line containing the date and the day of
the week in the format of “YYYY-MM-DD DayOfWeek”, where “DayOfWeek”
must be one of “Sunday”, “Monday”, “Tuesday”, “Wednesday”, “Thursday”,
“Friday” and “Saturday”.

Sample Input

1730
1740
1750
1751
-1

Sample Output

2004-09-26 Sunday

2004-10-06 Wednesday

2004-10-16 Saturday

2004-10-17 Sunday

代码:

#include<stdio.h>
int leap(int x)
{
    if(x%400==0||(x%4==0&&x%100!=0))
        return 1;
    else 
        return 0;
}
int main()
{
    int mon[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
    char week[7][10]={"Saturday","Sunday","Monday","Tuesday","Wednesday","Thursday","Friday"};
    long n,i,y=2000,k,d;
    while(scanf("%d",&n)!=EOF&&n!=-1)
    {y=2000;k=n;

    while(n>364)
    {
        if(!leap(y))
        {n-=365;y++;}//不是闰年,年数增加,天数减少365else
        { if(n>365){n-=366;y++;}//是闰年,年数增加,天数减少366else break;是闰年,天数没超过365天,年数不增加
        }
    }
    for(d=1,i=1;i<=12;i++)
    {
        if(leap(y)&&i==2)
        {
            mon[2]=29;n-=mon[i];//当年如果是闰年,且为2月时,当月的天数为29
        }
        else
            n-=mon[i];
        if(n<0)
            break;

    }
    d+=n+mon[i];
    printf("%d-%02d-%02d %s\n",y,i,d,week[k%7]);
    mon[2]=28;//月数变回28天
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值