【PAT】A1110 Complete Binary Tree (25 point(s))


Author: CHEN, Yue
Organization: 浙江大学
Time Limit: 400 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1110 Complete Binary Tree (25 point(s))

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

Code

#include <stdio.h>
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
struct NODE{
    int lchild,rchild;
};
vector<NODE> node;
int maxindex=-1,res;
void dfs(int root,int index){
    if(index>maxindex){
        maxindex=index;
        res=root;
    }
    if(node[root].lchild!=-1)   dfs(node[root].lchild,index*2);
    if(node[root].rchild!=-1)   dfs(node[root].rchild,index*2+1);
    return;
}
int main(){
    int n,haveroot[25]={0},root=0;
    string s1,s2;
    cin>>n;
    node.resize(n);
    for(int i=0;i<n;i++){
        int temp=-1;
        cin>>s1>>s2;
        if(s1=="-") node[i].lchild=-1;
        else{
            node[i].lchild=atoi(s1.c_str());
            haveroot[atoi(s1.c_str())]=1;
        }
        if(s2=="-") node[i].rchild=-1;
        else{
            node[i].rchild=atoi(s2.c_str());
            haveroot[atoi(s2.c_str())]=1;
        }
    }
    while(haveroot[root]!=0)    root++;
    dfs(root,1);
    if(maxindex==n) printf("YES %d\n",res);
    else    printf("NO %d\n",root);
    return 0;
}

Analysis

-判断一棵树是否是完全二叉树

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值