【PAT】A1115 Counting Nodes in a BST (30 point(s))


Author: CHEN, Yue
Organization: 浙江大学
Time Limit: 400 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1115 Counting Nodes in a BST (30 point(s))

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than or equal to the node’s key.
The right subtree of a node contains only nodes with keys greater than the node’s key.
Both the left and right subtrees must also be binary search trees.
Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−10001000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n
where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

Sample Output:

2 + 4 = 6

Code

#include <stdio.h>
int maxlevel=-1,cnt1=0,cnt2=0;
struct NODE{
    int data;
    struct NODE *lchild,*rchild;
};
NODE* build(NODE *root,int x){
    if(root==NULL){
        root=new NODE;
        root->data=x;
        root->lchild=root->rchild=NULL;
    }
    else if(x<=root->data)   root->lchild=build(root->lchild,x);
    else    root->rchild=build(root->rchild,x);
    return root;
}
void dfs(NODE *root,int level){
    if(root==NULL&&level>maxlevel)  maxlevel=level;
    if(root==NULL)  return;
    dfs(root->lchild,level+1);
    dfs(root->rchild,level+1);
}
void dfs2(NODE *root,int level){
    if(root==NULL)  return;
    if(level==maxlevel-1)   cnt1++;
    if(level==maxlevel-2)   cnt2++;
    dfs2(root->lchild,level+1);
    dfs2(root->rchild,level+1);
}
int main(){
    int n,temp;
    NODE* root=NULL;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d",&temp);
        root=build(root,temp);
    }
    dfs(root,1);;
    dfs2(root,1);
    printf("%d + %d = %d\n",cnt1,cnt2,cnt1+cnt2);
    return 0;
}

Analysis

-BST建树,找到倒数第一层和倒数第二层的结点数。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值