[PAT-Advanced] A1006 Sign In and Sign Out (25)

总题解目录

[PAT- Advanced Level] 甲级题解目录(Advanced Level)

A1006 Sign In and Sign Out (25point(s))

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

Analysis

  • 已知每个人的ID,以及他们进入实验室的时间和离开实验室的时间。
  • 求最早进入实验室的人和最晚离开实验室的人的ID,并输出。
  • 同时,由题意知,这些来计算机教室的人非常自律,从不加班到凌晨。
  • 题目还简化了情况,不考虑人来回进出,且进入时间一定比出门时间早,还不会有人同时进门或者出门。

C++ Code1

#include <stdio.h>
#include <stdlib.h>
typedef struct person{
	char id[20];
	int hi, mi, si, ho, mo, so;	// 进入时间的小时、分钟、秒;离开时间的小时、分钟、秒
}person;
person tp, tmin, tmax;
void set(){
	tmin.hi = 25;
	tmin.mi = 61;
	tmin.si = 61;
	tmax.ho = -1;
	tmax.mo = -1;
	tmax.so = -1;
}
int comparei(person a, person b){	// 比较谁先进入实验室,如果a比b先,则返回1;
	if (a.hi < b.hi)
		return 1;
	else if (a.hi == b.hi&&a.mi < b.mi)
		return 1;
	else if (a.hi == b.hi&&a.mi == b.mi&&a.si < b.si)
		return 1;
	else
		return 0;						//由题意,不会有同时打卡的两个人
}
int compareo(person a, person b){	// 比较谁后离开实验室,如果a比b后,则返回0;
	if (a.ho < b.ho)
		return 1;
	else if (a.ho == b.ho&&a.mo < b.mo)
		return 1;
	else if (a.ho == b.ho&&a.mo == b.mo&&a.so < b.so)
		return 1;
	else
		return 0;						//由题意,不会有同时打卡的两个人
}
int main(){
	set();
	int M;
	scanf("%d", &M);
	for (int i = 0; i < M; i++) {
		scanf("%s %d:%d:%d %d:%d:%d", tp.id, &tp.hi, &tp.mi, &tp.si, &tp.ho, &tp.mo, &tp.so);
		if (!comparei(tmin, tp))
			tmin = tp;
		if (compareo(tmax, tp))
			tmax = tp;
	}
	printf("%s %s\n", tmin.id, tmax.id);
	return 0;
}

C++ Code2

#include <stdio.h>
#include <stdlib.h>
#include <cstring>


int main(){
    char unlocked_id[20], locked_id[20], temp_id[20];
	int M, earliest=__INT_MAX__, latest=-1;
	scanf("%d", &M);

	while (M--) {
        int h1, m1, s1, h2, m2, s2;
		scanf("%s %d:%d:%d %d:%d:%d", temp_id, &h1, &m1, &s1, &h2, &m2, &s2);
        // 把所有时间按照秒来计数,即使是最晚,也不会超出int的范围。当然,以小时为单位用float存储也是可以的。
        int in_time = h1*3600 + m1*60 + s1;
        int out_time = h2*3600 + m2*60 + s2;
		if (in_time < earliest){
            memcpy(unlocked_id, temp_id, sizeof(unlocked_id));
            earliest = in_time;
        }
		if (out_time > latest){
            memcpy(locked_id, temp_id, sizeof(locked_id));
            latest = out_time;
        }
	}

	printf("%s %s", unlocked_id, locked_id);

	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值