[PAT-Advanced] A1008 Elevator (20)

总题解目录

[PAT- Advanced Level] 甲级题解目录(Advanced Level)

A1008 Elevator (20point(s))

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

Analysis

  • 已知电梯上行需6秒一层,下行需要4秒一层,到达一个楼层需要停止5秒。电梯初始在第0层(?还有第0层?),并且使用结束后不需要返回第0层。给出一个楼层访问序列,并且这些楼层数都是正数(0<n<100)。
  • 求按照访问序列,给出最后完成这些需求的总时间。
  • 注意,这里使用的是FCFS,先来先服务调度算法。

  • 能改的不多

C++ Code1

#include <stdio.h>
#include <stdlib.h>
int retime(int n){
	if (n > 0)	// 如果是上行(后-前>0)
		return 6 * n;
	else		// 如果是下行(后-前<0)
		return 4 * (-n);
}
int main(){
	int n, floor[110], result = 0;
	scanf("%d", &n);
	floor[0] = 0;
	for (int i = 1; i <= n; i++){
		scanf("%d", &floor[i]);
		result += retime(floor[i] - floor[i - 1]) + 5;	// 别忘了每层的停留时间!
	}
	printf("%d\n", result);
	return 0;
}

C++ Code2

#include <stdio.h>
#include <stdlib.h>


int waiting_time(int start, int end){
    int difference = end - start;
	if (difference >= 0)	return 6 * difference;	// 上行
	else	return 4 * (-difference);				// 下行
}


int main(){
	int n, now, previous = 0, total_time = 0;
	scanf("%d", &n);

	while (n--){
		scanf("%d", &now);
		total_time += waiting_time(previous, now) + 5;	// 别忘了每层的停留时间!
        previous = now;
	}

	printf("%d\n", total_time );

	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值