[PAT-Advanced] A1012 The Best Rank (25)

总题解目录

[PAT- Advanced Level] 甲级题解目录(Advanced Level)

A1012 The Best Rank (25point(s))

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

Analysis

  • 已知每个人的C(C语言) M(高数) E(英语)三门课的分数,先计算其均分A。
  • 之后给出一些学号,求给出的学号在所有人中4个分数(C M E A)中的最好排名。如果给出的学号没有成绩(之前未给出),输出N/A。

C++ Code

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#define MAX_N 10
#define MAX_STUDENT 2000

using namespace std;

// The priorities of the ranking methods are ordered as A > C > M > E.
char course[4] = { 'A', 'C', 'M', 'E' };
class Student{
    public:
        char id[MAX_N];
        double score[4];
        int rank[4];

        void get_avg_score();
};

void Student::get_avg_score(){
    score[0] = (score[1] + score[2] + score[3]) / 3.0;
}

Student students[MAX_STUDENT];
char sid[MAX_N];
int flag1 = -1;

bool cmp(Student a, Student b){
	return a.score[flag1] > b.score[flag1];
}

void ranks(int n){
	for (flag1 = 0; flag1 < 4; flag1++){
		sort(students, students + n, cmp);
		students[0].rank[flag1] = 1;
		for (int i = 1; i < n; i++){
			if (students[i].score[flag1] == students[i - 1].score[flag1])
				students[i].rank[flag1] = students[i - 1].rank[flag1];
			else
				students[i].rank[flag1] = i + 1;
		}
	}
}

void search(int n){
	bool flag = false;
	int num, min = MAX_STUDENT + 1;
	for (int i = 0; i < n; i++){
		if (!strcmp(sid, students[i].id)) {
			flag = true;
			for (flag1 = 0; flag1 < 4; flag1++){
				if (students[i].rank[flag1] < min){
					min = students[i].rank[flag1];
					num = flag1;
				}
			}
			break;
		}
	}
	if (flag)
		printf("%d %c\n", min, course[num]);
	else
		printf("N/A\n");
}

int main(){
	int n, m;
	scanf("%d %d", &n, &m);
	for (int i = 0; i < n; i++){
		scanf("%s %lf %lf %lf", students[i].id, &students[i].score[1], &students[i].score[2], &students[i].score[3]);
		students[i].get_avg_score();
	}
	ranks(n);
	for (int i = 0; i < m; i++){
		scanf("%s", sid);
		search(n);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值