[PAT-Advanced] A1020 Tree Traversals (25)

总题解目录

[PAT- Advanced Level] 甲级题解目录(Advanced Level)

A1020 Tree Traversals (25point(s))

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

Analysis

  • 已知一棵树的后序和中序遍历序列。
  • 求树的层序序列。

  • 几个函数都有非常高的复用性,熟记可举一反三

C++ Code

#include <stdio.h>
#include <stdlib.h>
#include <iostream>
#include <vector>
#include <queue>

using namespace std;

vector<int> inorder(35), levelorder, postorder(35);

struct NODE{
    int data;
    struct NODE *lchild, *rchild;
};
// 中序后序建树
NODE *build(int inl, int inr, int postl, int postr){
    if(postl > postr) return NULL;
    NODE *root = new NODE;
    root->data = postorder[postr];
    int i;
    for(i = inl; i <= inr; i++){
        if(postorder[postr] == inorder[i])
            break;
    }
    int lcnt = i - inl;
    root->lchild = build(inl, i - 1, postl, postl + lcnt - 1);
    root->rchild = build(i + 1, inr, postl + lcnt, postr - 1);
    return root;
}
// 层序遍历
void layer_order(NODE *root){
	queue<NODE*> q;
	q.push(root);
	while(!q.empty()){
        NODE *temp=q.front();
        q.pop();
        levelorder.push_back(temp->data);
        if(temp->lchild != NULL)    q.push(temp->lchild);
        if(temp->rchild != NULL)    q.push(temp->rchild);
	}
}

int main(){
    int n;
	scanf("%d", &n);
	for (int i = 0; i < n; i++) scanf("%d", &postorder[i]);
	for (int i = 0; i < n; i++) scanf("%d", &inorder[i]);

	NODE *root = build(0, n-1, 0, n-1);
	layer_order(root);
	for (int i = 0; i < levelorder.size(); i++){	// 按要求输出
        if (i)	printf(" ");
        printf("%d", levelorder[i]);
	}
	printf("\n");

	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值