【PAT】A1150 Travelling Salesman Problem (25point(s))


Author: CHEN, Yue
Organization: 浙江大学
Time Limit: 250 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1150 Travelling Salesman Problem (25point(s))

The “travelling salesman problem” asks the following question: “Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?” It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from “https://en.wikipedia.org/wiki/Travelling_salesman_problem”.)

In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:

n C​1​​ C​2​​ … C​n​​

where n is the number of cities in the list, and C​i​​ 's are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:

TS simple cycle if it is a simple cycle that visits every city;
TS cycle if it is a cycle that visits every city, but not a simple cycle;
Not a TS cycle if it is NOT a cycle that visits every city.
Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8

Code

#include <stdio.h>
#include <iostream>
#include <vector>
#include <string.h>
using namespace std;
int g[210][210],minDis=1e9,minIndex=1e9,visit[210],appr[210];
int n,m,k,n1,u,v,d,flag=0,sum=0;
vector<int> path;
int judge(int &sum){
    int flag=1;
    memset(visit,0,sizeof(visit));
    for(int i=1;i<=n;i++){
        if(appr[i]==0)		// 如果有顶点为出现过,则必不可能是题中要求的环或者简单环
            flag=-1;
    }
    if(path.size()>n+1&&path[0]==path[path.size()-1]) flag=0;	// 如果路径中的顶点数大于n+1,并且首位顶点相同
    if(path.size()<n+1||path[0]!=path[path.size()-1]) flag=-1;	// 如果路径中的定点数小于n+1,或者首位顶点不同
    for(int i=1;i<path.size();i++){
        if(g[path[i]][path[i-1]]!=0)    sum+=g[path[i]][path[i-1]];
        else    flag=-2;		// 有两顶点不可达,则路径长度不可求为NA
    }
    return flag;	// 如果以上所有其他情况都不发生,flag=1
}
int main(){
    cin>>n>>m;
    for(int i=0;i<m;i++){
        cin>>u>>v>>d;
        g[u][v]=g[v][u]=d;
    }
    cin>>k;
    for(int i=1;i<=k;i++){
        cin>>n1;
        path.clear();
        path.resize(n1);
        memset(appr,0,sizeof(appr));
        for(int j=0;j<n1;j++){
            cin>>path[j];
            appr[path[j]]=1;
        }
        printf("Path %d: ",i);
        int sum=0;
        flag=judge(sum);
        if(sum<minDis&&flag>=0){
            minDis=sum;
            minIndex=i;
        }
        if(flag==1)    printf("%d (TS simple cycle)\n",sum);
        else if(flag==0)    printf("%d (TS cycle)\n",sum);
        else if(flag==-1)   printf("%d (Not a TS cycle)\n",sum);
        else if(flag==-2)   printf("NA (Not a TS cycle)\n");
    }
    printf("Shortest Dist(%d) = %d\n",minIndex,minDis);
    return 0;
}

Analysis

-已知一张图的连接情况。并且给出M个访问序列。

-求给出的每个输入的访问序列的路径长度,并且给出该路径是否是经过所有顶点的简单环,经过所有顶点的环还是说不是前两种情况。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值