【PAT】A1133 Splitting A Linked List (25point(s))


Author: CHEN, Yue
Organization: 浙江大学
Time Limit: 400 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1133 Splitting A Linked List (25point(s))

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10^​5​​ ) which is the total number of nodes, and a positive K (≤10​^3​​ ). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer in [−10^​5​​ ,10​^5​​ ], and Next is the position of the next node. It is guaranteed that the list is not empty.

Output Specification:

For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218

Sample Output:

33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

Code

#include <stdio.h>
#include <iostream>
#include <vector>
#include <unordered_map>
using namespace std;
struct NODE{
    int add,data;
};
vector<NODE> v;
unordered_map<int,int> nxt,data;
int main(){
    int add,n,k,a,d,next,tempAdd;
    cin>>add>>n>>k;
    tempAdd=add;
    for(int i=0;i<n;i++){
        cin>>a>>d>>next;
        nxt[a]=next;
        data[a]=d;
    }
    while(add!=-1){
        NODE temp;
        temp.add=add;
        temp.data=data[add];
        if(data[add]<0) v.push_back(temp);
        add=nxt[add];
    }
    add=tempAdd;
    while(add!=-1){
        NODE temp;
        temp.add=add;
        temp.data=data[add];
        if(data[add]>=0&&data[add]<=k) v.push_back(temp);
        add=nxt[add];
    }
    add=tempAdd;
    while(add!=-1){
        NODE temp;
        temp.add=add;
        temp.data=data[add];
        if(data[add]>k) v.push_back(temp);
        add=nxt[add];
    }
    for(int i=0;i<v.size()-1;i++)
        printf("%05d %d %05d\n",v[i].add,v[i].data,v[i+1].add);
    printf("%05d %d -1\n",v[v.size()-1].add,v[v.size()-1].data);
    return 0;
}

Analysis

-按要求重新排序即可。将原静态链表按照(-∞,0).[0,k],(k,+∞),分为三部分。分块排序,要求有稳定性。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值