【PAT】A1122 Hamiltonian Cycle (25point(s))


Author: CHEN, Yue
Organization: 浙江大学
Time Limit: 300 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1122 Hamiltonian Cycle (25point(s))

The “Hamilton cycle problem” is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a “Hamiltonian cycle”.

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V​1​​ V​2​​ … V​n
​​
where n is the number of vertices in the list, and V​i​​ 's are the vertices on a path.

Output Specification:

For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

Code

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <vector>
using namespace std;
int g[210][210],showed[210];
vector<int> path;
bool judge(int n){
    if(path.size()!=n+1 || path[0]!=path[path.size()-1])    return false;
    memset(showed,0,sizeof(showed));
    for(int i=1;i<path.size();i++){
        if(g[path[i-1]][path[i]]!=1||showed[path[i]]==1)
            return false;
        showed[path[i]]=1;
    }
    return true;
}
int main(){
    int n,m,k,n1,a,b;
    scanf("%d %d",&n,&m);
    for(int i=0;i<m;i++){
        scanf("%d %d",&a,&b);
        g[a][b]=g[b][a]=1;
    }
    scanf("%d",&k);
    for(int i=0;i<k;i++){
        scanf("%d",&n1);
        path.clear();
        for(int j=0;j<n1;j++){
            scanf("%d",&a);
            path.push_back(a);
        }
        if(judge(n)==false) printf("NO\n");
        else    printf("YES\n");
    }
    return 0;
}

Analysis

-判断给出的图是不是Hamiltonian Cycle,某一个给出的序列应包括图中所有的点,且是一个简单环。

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值