【PAT】A1116 Come on! Let's C (20point(s))


Author: CHEN, Yue
Organization: 浙江大学
Time Limit: 200 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1116 Come on! Let’s C (20point(s))

“Let’s C” is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following:

0、 The Champion will receive a “Mystery Award” (such as a BIG collection of students’ research papers…).
1、 Those who ranked as a prime number will receive the best award – the Minions (小黄人)!
2、 Everyone else will receive chocolates.
Given the final ranklist and a sequence of contestant ID’s, you are supposed to tell the corresponding awards.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10^​4​​ ), the total number of contestants. Then N lines of the ranklist follow, each in order gives a contestant’s ID (a 4-digit number). After the ranklist, there is a positive integer K followed by K query ID’s.

Output Specification:

For each query, print in a line ID: award where the award is Mystery Award, or Minion, or Chocolate. If the ID is not in the ranklist, print Are you kidding? instead. If the ID has been checked before, print ID: Checked.

Sample Input:

6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222

Sample Output:

8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?

Code

#include <stdio.h>
#include <iostream>
#include <vector>
#include <math.h>
#include <map>
using namespace std;
map<int,string> award;
int isprinted[10010],isranked[10010];
bool isPrime(int n){
    if(n<=1)    return false;
    int sqr=(int)sqrt(n*1.0);
    for(int i=2;i<=sqr;i++)   if(n%i==0)  return false;
    return true;
}
int main(){
    int n,k,id;
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        scanf("%d",&id);
        if(i==1)    award[id]="Mystery Award";
        else if(isPrime(i)==true)   award[id]="Minion";
        else    award[id]="Chocolate";
        isranked[id]=1;
    }
    scanf("%d",&k);
    for(int i=0;i<k;i++){
        scanf("%d",&id);
        if(isprinted[id]==1&&isranked[id]==1)
            printf("%04d: Checked\n",id);
        else{
            if(isranked[id]==1) printf("%04d: %s\n",id,award[id].c_str());
            else    printf("%04d: Are you kidding?\n",id);
        }
        isprinted[id]=1;
    }
    return 0;
}

Analysis

-素数判断。给出K个ID的排序。

-第一个ID获得Mystery Award,素数位ID获得Minion,其余ID获得Chocolate。再给出若干个ID,输出其对应的获奖。如果未获奖,输出Are you kidding,如果之前已经输出过,则输出Checked。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值