【PAT】A1102 Invert a Binary Tree (25point(s))


Author: CHEN, Yue
Organization: 浙江大学
Time Limit: 400 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1102 Invert a Binary Tree (25point(s))

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can’t invert a binary tree on a whiteboard so fuck off.

Now it’s your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

Code

#include <stdio.h>
#include <iostream>
#include <vector>
#include <queue>
using namespace std;
struct NODE{
    int data,lchild,rchild;
};
vector<NODE> tree;
vector<int> level,in;
int havePar[20];
void inLevelOrder(int root){
    queue<int> q;
    q.push(root);
    while(!q.empty()){
        int temp=q.front();
        q.pop();
        level.push_back(temp);
        if(tree[temp].lchild!=-1)   q.push(tree[temp].lchild);
        if(tree[temp].rchild!=-1)   q.push(tree[temp].rchild);
    }
}
void inInOrder(int root){
    if(root==-1)    return;
    inInOrder(tree[root].lchild);
    in.push_back(tree[root].data);
    inInOrder(tree[root].rchild);
}
int main(){
    int n;
    char a,b;
    scanf("%d",&n);
    tree.resize(n);
    for(int i=0;i<n;i++){
        getchar();
        scanf("%c %c",&a,&b);
        tree[i].data=i;
        if(a=='-')  tree[i].rchild=-1;
        else{
            tree[i].rchild=a-'0';
            havePar[a-'0']=1;
        }
        if(b=='-')  tree[i].lchild=-1;
        else{
            tree[i].lchild=b-'0';
            havePar[b-'0']=1;
        }

    }
    for(int i=0;i<n;i++){		// 结点无父结点
        if(havePar[i]==0){
            inLevelOrder(i);
            inInOrder(i);
            break;
        }
    }
    for(int i=0;i<level.size();i++){
        if(i==0)    printf("%d",level[i]);
        else        printf(" %d",level[i]);
    }
    printf("\n");
    for(int i=0;i<in.size();i++){
        if(i==0)    printf("%d",in[i]);
        else    printf(" %d",in[i]);
    }
    return 0;
}

Analysis

-给出一棵树求其逆着的树的层序和中序遍历。

-注:我在输入时就将左右孩子互换了位置。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值