[PAT-Advanced] A1024 Palindromic Number (25)


总题解目录

[PAT- Advanced Level] 甲级题解目录(Advanced Level)

A1024. Palindromic Number (25)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 10^10) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

Analysis

  • 回文数,1234321 是一个回文数。 所有个位数的数字都是回文数字。
  • 存数字的时候,倒着存比较方便进位。

C++ Code

//NKW 甲级练习题1035
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <vector>
#include <algorithm>
using namespace std;

vector<int> vi, vr;

bool ispal(){
	for (int i = 0; i < vi.size() / 2; i++)
		if (vi[i] != vi[vi.size() - i - 1])
			return false;
	return true;
}

int main(){
	long long num, k, step = 0;
	scanf("%lld %lld", &num, &k);
	do{
		vi.push_back(num % 10);
		num /= 10;
	} while (num);
	while (k--){
		if (ispal())	break;
		vr = vi;
		reverse(vi.begin(), vi.end());
		for (int i = vr.size() - 1; i >= 0; i--)
			vr[i] += vi[i];
		for (int i = vr.size() - 1; i > 0; i--){
			if (vr[i] / 10){
				vr[i - 1] += vr[i] / 10;
				vr[i] %= 10;
			}
		}
		vi.clear();
		if (vr[0] / 10){
			vi.push_back(vr[0] / 10);
			vr[0] %= 10;
		}
		for (int i = 0; i < vr.size(); i++)
			vi.push_back(vr[i]);
		step++;
	}
	for (int i = 0; i < vi.size(); i++)
		printf("%d", vi[i]);
	printf("\n%d\n", step);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值