[PAT-Advanced] A1071. Speech Patterns (25)

总题解目录

[PAT- Advanced Level] 甲级题解目录(Advanced Level)

A1071. Speech Patterns (25)

People often have a preference among synonyms of the same word. For example, some may prefer “the police”, while others may prefer “the cops”. Analyzing such patterns can help to narrow down a speaker’s identity, which is useful when validating, for example, whether it’s still the same person behind an online avatar.

Now given a paragraph of text sampled from someone’s speech, can you find the person’s most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a “word” is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:

Can1: “Can a can can a can? It can!”

Sample Output:

can 5

Analysis

  • 给出一个字符串,求出现的合法的单词的个数最多的那个单词,以及它出现的次数。如果有并列的,那么输出字典序里面的第一个。
  • 注意:大小写字母+数字的组合才是合法的单词,

C++ Code

//NKW 甲级真题1027
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <map>
#include <string>

using namespace std;

map<string, int> mp;
string sg, s;

bool check(char &c){
	if (c >= 'a'&&c <= 'z')	return true;
	if (c >= 'A'&&c <= 'Z')	{
		c += 32;
		return true;
	}
	if (c >= '0'&&c <= '9')	return true;
	return false;
}

int main(){
	getline(cin, sg);
	for (int i = 0; i < sg.length(); i++){
		if (check(sg[i]))
			s += sg[i];                                                    
		if(!check(sg[i]) || i==sg.length()-1){    
    //这个地方挺关键,防止最后一位是合法输入,导致最后一个单词未输入导致结果出问题
			if (s.length() != 0)
				mp[s]++;
			s.clear();
		}
	}
	s.clear();
	
	int max = -1;
	for (map<string, int>::iterator it = mp.begin(); it != mp.end(); it++){
		if (it->second > max){
			s = it->first;
			max = it->second;
		}
	}
	printf("%s %d\n", s.c_str(), max);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值