【PAT】A1077. Kuchiguse (20)

A1077. Kuchiguse (20)

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:

Itai nyan~ (It hurts, nyan~)
Ninjin wa iyada nyan~ (I hate carrots, nyan~)
Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2<=N<=100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write “nai”.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~

uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T

T_T

Sample Output 2:

nai

Code

//NKW 甲级真题1012
#pragma warning(disable:4996)
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int maxn1 = 110;
const int maxn2 = 260;
char v[maxn1][maxn2];
int main(){
	int n, num = 0, minlen = 300;
	scanf("%d", &n);
	char kuchiguse[maxn2];
	char c;
	bool flag = true;
	getchar();				//接收数字后的换行符
	for (int i = 0; i < n; i++){
		fgets(v[i], maxn2, stdin);		//PTA网站如果使用C++(g++)编译不能使用get(),如果使用c(gcc)编译不能使用C++头文件
		if (v[i][strlen(v[i]) - 1] == '\n')	//此处需用fgets()替代gets(),并且把换行符去了,fgets()把换行符也接收了
		    v[i][strlen(v[i]) - 1] = '\0';	//还能使用getline(cin,v[i]),#include <iostream> #include <string>
		if (minlen > strlen(v[i]))
			minlen = strlen(v[i]);
		reverse(v[i], v[i] + strlen(v[i]));
	}
	for (int i = 0; i < minlen; i++){
		for (int j = 0; j < n; j++){
			c = v[0][i];
			if (c != v[j][i]){
				flag = false;
				break;
			}
		}
		if (flag)
			kuchiguse[num++] = c;
		else
			break;
	}
	kuchiguse[num] = '\0';
	reverse(kuchiguse, kuchiguse + strlen(kuchiguse));
	if (strlen(kuchiguse))
		printf("%s\n", kuchiguse);
	else
		printf("nai\n");
	system("pause");
	return 0;
}

Analysis

-本题将数组逆置转而求公共前缀让解题更加方便。

-另外,PAT的编译器在C++编译环境下不能使用gets(),我们用fgets(char* a,int maxlens,stdin)替代。(注意,前面需要用getchar()接收一下换行符,因为大部分题目在接收整行数据前,有一个数据个数的输入)。

fgets(v[i], maxn2, stdin);	//PTA网站如果使用C++(g++)编译不能使用get(),如果使用c(gcc)编译不能使用C++头文件
if (v[i][strlen(v[i]) - 1] == '\n')	//此处需用fgets()替代gets(),并且把换行符去了,fgets()把换行符也接收了
    v[i][strlen(v[i]) - 1] = '\0';	//还能使用getline(cin,v[i]),#include <iostream> #include <string>

 

  • 2
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值