【PAT】A1067. Sort with Swap(0,*) (25)

Author: CHEN, Yue

Organization: 浙江大学

Time Limit: 200 ms

Memory Limit: 64 MB

Code Size Limit: 16 KB

A1067. Sort with Swap(0,*) (25)

Given any permutation of the numbers {0, 1, 2,…, N-1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (<=10^5) followed by a permutation sequence of {0, 1, …, N-1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10 3 5 7 2 6 4 9 0 8 1

Sample Output:

9

Code

//NKW 甲级真题1025
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
const int maxn = 100010;
int a1[maxn];
int main(){
	int n, left = 0, num;
	scanf("%d", &n);
	for (int i = 0; i < n; i++){
		scanf("%d", &num);
		a1[num] = i;			//num的位置为i
		if (num != i&&num != 0)
			left++;				//num非0,并且不在对应的位置上
	}
	int k = 1, cnt = 0;
	while (left > 0){
		if (a1[0] == 0){
			while (k < n){
				if (a1[k] != k){
					swap(a1[0], a1[k]);
					cnt++;
					break;
				}
				k++;		//很关键,
			}
		}
		while (a1[0] != 0){
			swap(a1[0], a1[a1[0]]);
			cnt++;
			left--;
		}
	}
	printf("%d\n", cnt);
	return 0;
}

Analysis

-已知⼀个n个数的序列,数字为0~n-1的乱序,每次⽤两两交换的⽅式⽽且只能⽤0和另⼀个数交换。

-求最少需要交换几次才能使序列变成有序的。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值