【PAT】A1081. Rational Sum (20)

Author: CHEN, Yue

Organization: 浙江大学

Time Limit: 400 ms

Memory Limit: 64 MB

Code Size Limit: 16 KB

A1081. Rational Sum (20)

Given N rational numbers in the form “numerator/denominator”, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers “a1/b1 a2/b2 …” where all the numerators and denominators are in the range of “long int”. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form “integer numerator/denominator” where “integer” is the integer part of the sum, “numerator” < “denominator”, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24

Code

//NKW 甲级练习题1001
#include <stdio.h>
#include <stdlib.h>
long long gcd(long long a, long long b){
	return b == 0 ? a : gcd(b,a%b);
}
typedef struct rational{
	long long numerator, denominator;
	rational(){
		numerator = 0;
		denominator = 1;
	}
}rational;
rational reduction(rational a){
	if (a.denominator < 0){
		a.numerator = -a.numerator;
		a.denominator = -a.denominator;
	}
	if (a.numerator == 0)
		a.denominator = 1;
	else{
		int d = gcd(abs(a.numerator), abs(a.denominator));
		a.numerator /= d;
		a.denominator /= d;
	}
	return a;
}
void printrational(rational a){
	if (a.denominator == 1)
		printf("%lld\n", a.numerator);
	else if (abs(a.numerator)>a.denominator)
		printf("%lld %lld/%lld\n", a.numerator / a.denominator, abs(a.numerator) % a.denominator, a.denominator);
	else
		printf("%lld/%lld\n", a.numerator, a.denominator);
}
rational sum, num;
int main(){
	int n;
	scanf("%d", &n);
	for (int i = 0; i < n; i++){
		scanf("%lld/%lld", &num.numerator, &num.denominator);
		sum.numerator = sum.numerator * num.denominator + num.numerator * sum.denominator;
		sum.denominator = sum.denominator * num.denominator;
		sum = reduction(sum);
	}
	printrational(sum);
	return 0;
}

Analysis

-给出 n 个分数,求分数的和。分数前面可能有负号。若答案为假分数,则按照带分数形式输出;整数按照整数输出;否则按照真分数输出。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值