【PAT】A1060. Are They Equal (25)

Author: CHEN, Yue

Organization: 浙江大学

Time Limit: 400 ms

Memory Limit: 64 MB

Code Size Limit: 16 KB

A1060. Are They Equal (25)

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123*105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line “YES” if the two numbers are treated equal, and then the number in the standard form “0.d1…dN*10^k” (d1>0 unless the number is 0); or “NO” if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

Code

//NKW 甲级真题1020
#include <iostream>
#include <stdlib.h>
#include <string>
using namespace std;
int n, ea = 0, eb = 0;
string sa, sb;
string deal(string s, int &e){
	while (s.length() && s[0] == '0')
		s.erase(s.begin());
	if (s[0] == '.'){
		s.erase(s.begin());
		while (s.length() && s[0] == '0'){
			s.erase(s.begin());
			e--;
		}
	}
	else{
		for (int i = 0; i < s.length(); i++){
			if (s[i] == '.'){
				s.erase(s.begin() + i);
				e = i;
				break;
			}
		}
		if (e == 0)
			e = s.length();
	}
	while (s.length() < n)
		s += '0';
	return s.substr(0, n);
}
int main(){
	cin >> n >> sa >> sb;
	sa = deal(sa, ea);
	sb = deal(sb, eb);
	if (sa == sb)
		cout << "YES 0." << sa << "*10^" << ea << endl;
	else
		cout << "NO 0." << sa << "*10^" << ea << " 0." << sb << "*10^" << eb << endl;
	return 0;
}

Analysis

-用科学表示法时是否相同

-注意,本题需要删除前置零。测试点有0000XX的输入。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值