【PAT】A1091. Acute Stroke (30)

Author: CHEN, Yue

Organization: 浙江大学

Time Limit: 600 ms

Memory Limit: 64 MB

Code Size Limit: 16 KB

A1091. Acute Stroke (30)

One important factor to identify acute stroke (急性脑卒中) is the volume of the stroke core. Given the results of image analysis in which the core regions are identified in each MRI slice, your job is to calculate the volume of the stroke core.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: M, N, L and T, where M and N are the sizes of each slice (i.e. pixels of a slice are in an M by N matrix, and the maximum resolution is 1286 by 128); L (<=60) is the number of slices of a brain; and T is the integer threshold (i.e. if the volume of a connected core is less than T, then that core must not be counted).

Then L slices are given. Each slice is represented by an M by N matrix of 0’s and 1’s, where 1 represents a pixel of stroke, and 0 means normal. Since the thickness of a slice is a constant, we only have to count the number of 1’s to obtain the volume. However, there might be several separated core regions in a brain, and only those with their volumes no less than T are counted. Two pixels are “connected” and hence belong to the same region if they share a common side, as shown by Figure 1 where all the 6 red pixels are connected to the blue one.
 


Output Specification:

For each case, output in a line the total volume of the stroke core.

Sample Input:

3 4 5 2
1 1 1 1
1 1 1 1
1 1 1 1
0 0 1 1
0 0 1 1
0 0 1 1
1 0 1 1
0 1 0 0
0 0 0 0
1 0 1 1
0 0 0 0
0 0 0 0
0 0 0 1
0 0 0 1
1 0 0 0

Sample Output:

26

Code

//NKW 甲级真题1004
#include <stdio.h>
#include <stdlib.h>
#include <queue>
using namespace std;
struct node{
	int x, y, z;
}p;
int m, n, l, t, volume = 0;
int brain[1300][130][61], bbrain[1300][130][61];
//右,左,上,下,前,后
int X[] = { 0, 0, 0, 0, 1, -1 };
int Y[] = { 1, -1, 0, 0, 0, 0 };
int Z[] = { 0, 0, 1, -1, 0, 0 };
bool judge(int x, int y, int z){
	if (x >= m || x < 0 || y >= n || y < 0 || z >= l || z < 0)	return false;
	if (!brain[x][y][z] || bbrain[x][y][z])	return false;
	return true;
}
int BFS(int x, int y, int z){
	int cnt = 0;
	queue<node> qn;
	p.x = x;
	p.y = y;
	p.z = z;
	qn.push(p);
	bbrain[x][y][z] = 1;
	while (!qn.empty()){
		node top = qn.front();
		qn.pop();
		cnt++;
		for (int i = 0; i < 6; i++){
			int nx = top.x + X[i], ny = top.y + Y[i], nz = top.z + Z[i];
			if (judge(nx, ny, nz)){
				p.x = nx;
				p.y = ny;
				p.z = nz;
				qn.push(p);
				bbrain[nx][ny][nz] = 1;
			}
		}
	}
	if (cnt >= t)	return cnt;
	else return 0;
}
int main(){
	scanf("%d %d %d %d", &m, &n, &l, &t);
	for (int k = 0; k < l; k++)
		for (int i = 0; i < m; i++)
			for (int j = 0; j < n; j++)
				scanf("%d", &brain[i][j][k]);
	for (int i = 0; i < m; i++)
		for (int j = 0; j < n; j++)
			for (int k = 0; k < l; k++)
				if (brain[i][j][k] && bbrain[i][j][k] == 0)
					volume += BFS(i, j, k);
	printf("%d\n", volume);
	return 0;
}

Analysis

-使用BFS判断立体图形连续单元大小。

-使用三个数组x[],y[],z[]存入对应数,i从0到5共六个下标,分别表示向右,向左,向上,向下,向前,向后移动。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值