【PAT】A1079. Total Sales of Supply Chain (25)

Author: CHEN, Yue

Organization: 浙江大学

Time Limit: 250 ms

Memory Limit: 64 MB

Code Size Limit: 16 KB

A1079. Total Sales of Supply Chain (25)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)– everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N-1, and the root supplier’s ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] … ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:

42.4

Code

//NKW 甲级练习题1014
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <vector>
using namespace std;
const int maxn = 100010;
vector<int> k[maxn];
int n, ki, id, product[maxn], cnt[maxn];
double p, r, inc, sum = 0;
void tri(int root, int pri){
	cnt[root] = cnt[pri] + 1;
	if (k[root][0] == -1){
		sum += product[root] * p * pow(inc, cnt[root] - 1);
		return;
	}
	for (int i = 0; i < k[root].size(); i++)
		tri(k[root][i], root);
}
int main(){
	scanf("%d %lf %lf", &n, &p, &r);
	inc = 1 + r / 100;
	for (int i = 0; i < n; i++){
		scanf("%d", &ki);
		for (int j = 0; j < ki; j++){
			scanf("%d", &id);
			k[i].push_back(id);
		}
		if (ki == 0){
			scanf("%d", &id);
			product[i] = id;
			k[i].push_back(-1);
		}
	}
	tri(0, 0);
	printf("%.1f\n", round(sum * 10) / 10);
	return 0;
}

Analysis

-给出一颗供应销售的树。树根唯一,在树根处货物的价格为 P,然后从根节点开始往每一个子节点上走一层,该层的货物价格将会在父亲节点的价格上增加 r%。给出每个叶结点的货物量,求他们的价格之和

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值