【PAT】A1108 Finding Average(20)


Author: CHEN, Yue
Organization: 浙江大学
Time Limit: 400 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1108 Finding Average (20 point(s))

he basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2

2
aaa -9999

Sample Output 2

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

Code

#include <iostream>
//#include <fstream>
#include <string.h>
using namespace std;
int main() {
    //ifstream cin("/home/my/Desktop/in.txt");
    int n, cnt = 0;					// n:输入数据个数,cnt:符合条件的数字计数
    double sum = 0.0;				// sum:和
    char s1[50], s2[50];			// s1,s2:存储处理前后的字符串
    cin >> n;
    for(int i = 0; i < n; i++){
        cin >> s1;
        double temp = 1001;			// 初始化temp为不符合要求的数字
        bool flag = 0;				// flag:判断是否是浮点数
        sscanf(s1, "%lf", &temp);	// 取出s1从第一个字符开始看,double型的数
        sprintf(s2, "%.2f", temp);	// 将数取两位小数
        // 如果精确到两位小数后的数(字符串形式),与原字符串不同,则输入的不是精确到2位小数的实数
        for(int j = 0; j < strlen(s1); j++) if(s1[j] != s2[j])   flag = 1;
        if(flag || temp < -1000 || temp >1000)  printf("ERROR: %s is not a legal number\n", s1);
        else{	// 满足条件
            sum += temp;
            cnt++;
        }
    }
    if(cnt > 1)         printf("The average of %d numbers is %.2f\n", cnt, sum / cnt);
    else if(cnt == 1)   printf("The average of 1 number is %.2f\n", sum);
    else                printf("The average of 0 numbers is Undefined\n");
    return 0;
}

Analyze

  1. 通过输出测试我们可以看到,对于输入aaa,sscanf不会将任何结果输入temp。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值