【PAT】A1155 Heap Paths (30 point(s))


Author: 陈越
Organization: 浙江大学
Time Limit: 400 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1155 Heap Paths (30point(s))

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

Code

#include <stdio.h>
#include <iostream>
#include <vector>
using namespace std;
vector<int> path,level;
int n,ismin=1,ismax=1;
void dfs(int root){	// dfs用于输出路径,注意题中的要求:先右后左
    if(root*2>n){
        for(int i=0;i<path.size();i++){
            if(i==0)    printf("%d",path[i]);
            else    printf(" %d",path[i]);
        }
        printf("\n");
        return;
    }
    if(root*2+1<=n){	// 先右,有右子树
        path.push_back(level[root*2+1]);
        dfs(root*2+1);
        path.pop_back();
    }
    if(root*2<=n){		// 后左,有左子树
        path.push_back(level[root*2]);
        dfs(root*2);
        path.pop_back();
    }
}
int main(){
    cin>>n;
    level.resize(n+1);
    for(int i=1;i<=n;i++)   cin>>level[i];
    path.push_back(level[1]);
    dfs(1);
    path.pop_back();
    for(int i=1;i<=n;i++){	// 分只有左子树和有两个子树两种情况
        if(i*2<=n && i*2+1<=n){		// 只要有一个结点不满足,对应标志就置0
            if(!(level[i]>level[i*2]&&level[i]>level[i*2+1]))   ismax=0;
            if(!(level[i]<level[i*2]&&level[i]<level[i*2+1]))   ismin=0;
        }
        else if(i*2<=n && i*2+1>n){	// 只要有一个结点不满足,对应标志就置0
            if(!(level[i]>level[i*2]))   ismax=0;
            if(!(level[i]<level[i*2]))   ismin=0;
        }
    }
    // 按照标志的结果输出对应判断结果
    if(ismax==1)    printf("Max Heap\n");
    else if(ismin==1)   printf("Min Heap\n");
    else    printf("Not Heap\n");
    return 0;
}

Analysis

-已知一棵树的层序遍历。

-输出根到每一个叶结点的路径,并且判断这棵树是大顶堆还是小顶堆或者根本不是堆。

-注意,题中要求输出根到叶结点的路径时要先右后左。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值