【PAT】A1154 Vertex Coloring (25 point(s))


Author: 陈越
Organization: 浙江大学
Time Limit: 900 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1154 Vertex Coloring (25point(s))

A proper vertex coloring is a labeling of the graph’s vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10^​4​​ ), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

Code

#include <iostream>
#include <stdio.h>
#include <vector>
#include <string.h>
#include <queue>
#include <unordered_set>
using namespace std;

vector<int> near[10000];
int vis[10000];
int color[10000];

bool BFS(int root){	// 判断两相邻结点的颜色是否相同
    queue<int> q;
    q.push(root);
    vis[root]=1;
    while(!q.empty()){
        int temp=q.front();
        q.pop();
        for(int i=0;i<near[temp].size();i++){
            if(vis[near[temp][i] ]==0){
                vis[near[temp][i] ]=1;
                q.push(near[temp][i]);
            }
            if(color[temp]==color[near[temp][i] ])	// 如果相同返回false
                return false;
        }
    }
    return true;	// 如果都不相同返回true
}

int main(){
    int n,m,u,v;
    cin>>n>>m;
    for(int i=0;i<m;i++){
        cin>>u>>v;
        near[u].push_back(v);
        near[v].push_back(u);
    }
    int k;
    cin>>k;
    for(int i=0;i<k;i++){
        unordered_set<int> us;		// us的大小即使用的颜色数
        memset(color,-1,sizeof(color));
        memset(vis,0,sizeof(vis));
        for(int j=0;j<n;j++){
            cin>>u;
            us.insert(u);
            color[j]=u;
        }
        if(BFS(0))  printf("%d-coloring\n",us.size());
        else    printf("No\n");
    }
    return 0;
}

Analysis

-已知一个图各结点间的连通关系。以及k个上色方案。

-求给出的上色方案能否让图中两相邻结点的颜色(颜色用编号表示)不同。如果可以,输出 k-coloring ,其中k表示使用了k种颜色。如果不可以,输出 No 。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值