【PAT】A1145 Hashing - Average Search Time (25 point(s))


作者: CHEN, Yue
单位: 浙江大学
时间限制: 200 ms
内存限制: 64 MB
代码长度限制: 16 KB

A1145 Hashing - Average Search Time (25 point(s))

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 10^ 4. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 10^ ​5.

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

Sample Output:

15 cannot be inserted.
2.8

Code

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <vector>
using namespace std;
int table[100010];
bool isPrime(int n){
    if(n<=1)    return false;
    int sqr=sqrt(1.0*n);
    for(int i=2;i<=sqr;i++)
        if(n%i==0)  return false;
    return true;
}
int main(){
    int MSize,n,m,temp;
    scanf("%d %d %d",&MSize,&n,&m);
    while(isPrime(MSize)==false)    MSize++;
    for(int i=0;i<n;i++){
        scanf("%d",&temp);
        int isInsert=0;
        for(int j=0;j<MSize;j++){
            int add=(temp+j*j)%MSize;
            if(table[add]==0){
                table[add]=temp;
                isInsert=1;
                break;
            }
        }
        if(isInsert==0) printf("%d cannot be inserted.\n",temp);
    }
    int fcnt=0;
    for(int i=0;i<m;i++){
        scanf("%d",&temp);
        for(int j=0;j<=MSize;j++){
            fcnt++;
            int add=(temp+j*j)%MSize;
            if(table[add]==temp||table[add]==0) break;
        }
    }
    printf("%.1f\n",fcnt * 1.0/m);
    return 0;
}

Analysis

-给出表长MSize,要插入的n个点,要查询的m个点。进行哈希表的插入和查询。

-找到不小于初始MSize的最小质数,作为新的MSize。哈希函数为:H(key)=key%MSize。利用平方探测法处理冲突(题中要求只有正增量)。有点不能插入就输出不能插入。对于m个点的查询,输出平均查找次数,保留一位小数。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值