【PAT】A1107 Social Clusters (30 point(s))


Author: CHEN, Yue
Organization: 浙江大学
Time Limit: 1200 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1107 Social Clusters (30 point(s))

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​ : h​i​​ [1] h​i[2] … h​i[K​i]

where K​i​(>0) is the number of hobbies, and h​i​​ [j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

Code

#include <stdio.h>
#include <vector>
#include <algorithm>
using namespace std;
vector<int> res,father;
bool cmp(int a,int b){return a>b;}
int findFather(int x){
    if(x==father[x])    return x;
    else{
        int F=findFather(father[x]);
        father[x]=F;
        return F;
    }
}
void Union(int a,int b){
    int faA=findFather(a),faB=findFather(b);
    if(faA!=faB)    father[faA]=faB;
}
int main(){
    int n,k,h,hobbies[1010]={0},cnt=0;
    scanf("%d",&n);
    father.resize(n+1);
    res.resize(n+1);
    for(int i=1;i<=n;i++)   father[i]=i;
    for(int i=1;i<=n;i++){
        scanf("%d:",&k);
        for(int j=0;j<k;j++){
            scanf("%d",&h);
            if(hobbies[h]==0)   hobbies[h]=i;
            else    Union(i,hobbies[h]);
        }
    }
    for(int i=1;i<=n;i++)   res[findFather(i)]++;
    for(int i=1;i<=n;i++)   if(res[i]!=0)   cnt++;
    printf("%d\n",cnt);
    sort(res.begin(),res.end(),cmp);
    for(int i=0;i<cnt;i++){
        if(i==0)    printf("%d",res[i]);
        else    printf(" %d",res[i]);
    }
    return 0;
}

Analysis

-找到社交活动中兴趣相投的人。兴趣相投的人(有点关系的就)被分到一组。最后输出有几组,并且按照每组的人数降序输出每组的人数。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值