uva 307 Sticks

Sticks

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input file contains blocks of 2 lines. The first line contains the number of sticks parts after cutting. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output file contains the smallest possible length of original sticks, one per line.

Sample Input

9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0

Sample Output

6
5

题目的意思是  看下下列是数据 能否加起来得 四条边的长度相等

果断的暴力搜索,一条边一条边的来,注意得剪枝;

 

 

#include<cstdio>
#include<cstring>
#include<cstdlib>
int sum,num;
int s[65];
int biaoji[65];
int n,k;
int com(const void *a1, const void *a2)
{
    return *(int *)a2-*(int *)a1;
}
bool sousuo(int jige,int changdu,int weizhi)//jige表示当前有多少个木棒  changdu表示目前加起来的木棒长度 weizhi表示所有木棒的坐标 
{
	int i;
	bool sign=(changdu==0?true:false);
	if(jige==num)  return true;
	for(i=weizhi+1;i<n;i++)
	{
		if(biaoji[i])continue;
		if(changdu+s[i]==k)
		{
			biaoji[i]=1;
			if(sousuo(jige+1,0,-1))
			return true;
			biaoji[i]=0;
			return false;
		}
		else if(changdu+s[i]<k)
		{
			biaoji[i]=1;
			if(sousuo(jige,changdu+s[i],i))
			return true;
			biaoji[i]=0;
			if(sign) return false;
			while(s[i]==s[i+1]) i++;
		}
	}
	return false;
}
int main()
{
	while(~scanf("%d",&n)&&n)
	{
		sum=0;
		int i;
	for(i=0;i<n;i++)
	{
		
		scanf("%d",&s[i]);
		sum+=s[i];
	}
	qsort(s,n,sizeof(s[0]),com);
	for(k=s[0];k<=sum;k++)
	{
		if(sum%k==0)
		{
			num=sum/k;
			memset(biaoji,0,sizeof(biaoji));
			if(sousuo(1,0,-1))
			{
				printf("%d\n",k);
				break;
			}
		}
	}
	}
	return 0;
}


 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值