hdu 1541 Stars

Problem Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1

0

该题是一个树状数组的基础题。刚学树状数组,有点难写,

不过题意懂了 ,模版套下,还是简单的。

题目的意思就是。给你一个x y坐标,然后,组成一个树状图形,

让你求左下角星星数目相等的 等级数有几个。, 也就是0到n,

求拥有相等个数的星星的个数。

因为坐标是从0开始的,而树状数组无法从0开始,故 x++(一个好大的wa点)。

然后计算次坐标之前的星星总数,调用sum函数,以之前的不同位置的星星求和。

然后更新每个位置的星星的个数、

#include <iostream>
#include <cstring>
using namespace std;
int xingxing[15010];
int ji[32010];

int lowbit(int x)
{
	return x&(-x);
}

void updata(int x)
{
	while(x<32010)
	{
		++ji[x];
		x+=lowbit(x);
	}
}

int suM(int x)
{
	int sum=0;
	while(x>0)
	{
		sum+=ji[x];
		x-=lowbit(x);
	}
	return sum;
}

int main() 
{
    int n,x,y,i;
    while(cin>>n)
    {
    	memset(xingxing,0,sizeof(xingxing));
    	memset(ji,0,sizeof(ji));
    	for(i=0;i<n;i++)
    	{
    		cin>>x>>y;
    		x++;
    		xingxing[suM(x)]++; //几个星星数组的变化 
    		updata(x); //更新星星的个数 
    	}
		for(i=0;i<n;i++)
   		 cout<<xingxing[i]<<endl;
    }
    
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值