hdu 1671 Phone List

Problem Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES
 
 
 
 
本题的题意是,给你n个串的电话号码。问有没有可能一个电话号码是其他的 号码的前缀,、
比如911 它就是91156的前缀。如果有的话输出NO。没有则输出YES
这题的解法就是字典树,首先套用字典树的模板,建立字典树,注意清空root
然后将输入的电话号码存入字典树里面,然后寻找遍历字典树,如果遍历完一个电话号码
之后,看后面的节点是否为空,如果不为空,说明有其他的电话号码是以这个前缀的,标记,
然后判断输出;,,而且注意一点就是结束之后记得清空,不然很容易mle。具体实现如下:
 
 
#include<iostream>
#include<cstring>
#include<stdio.h>
#include<stdlib.h>
using namespace std;
struct node
{
	struct node *next[10];
};

struct node *root;
void charu(char *qq)
{
	struct node *now1,*now2;
	int i,j;
	int l=strlen(qq);
	now1=root;
	
	for(i=0;i<l;i++)
	{
		int k=qq[i]-'0';
		if(now1->next[k]) now1=now1->next[k];
		else 
		{
			now2=new struct node;
			for(j=0;j<10;j++) now2->next[j]=0;
			now1->next[k]=now2;
			now1=now2;
		}
	}
}
int find(char *s)
{
	int i;
	struct node *now;
	now=root;
	int flag;
	int l=strlen(s);
	
	for(i=0;i<l;i++) now=now->next[s[i]-'0'];
	flag=0;
	for(i=0;i<10;i++) 
	if(now->next[i])
	{
		flag=1; break;
	}

}
void qing(struct node *pp)
{
	int i;
	for(i=0;i<10;i++)
	if(pp->next[i])
	qing(pp->next[i]);
	delete(pp);
}

int main()
{
	int bbs,n,i,j,ans;
	char ss[10010][12];
	cin>>bbs;
	while(bbs--)
	{
		cin>>n;
		root=new struct node;
		for(i=0;i<10;i++) root->next[i]=0;
		
		for(i=0;i<n;i++)
		{
			scanf("%s",ss[i]);
			charu(ss[i]);
		}
		ans=0;
		for(i=0;i<n;i++)
		{
			ans=find(ss[i]);
			if(ans)  break;
		}
		if(ans)  cout<<"NO"<<endl;
		else cout<<"YES"<<endl;
		qing(root);
	}
	return 0;
	
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值