HDU:1069 Monkey and Banana(经典动态规划DP)

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12752    Accepted Submission(s): 6683


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
  
  
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
  
  
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
 

Source
 

Recommend
JGShining
题目大意: 给出一些长方体的长宽高,然后让你把它们堆成塔, 要求下面的长方体的要比上面的塔大(长和宽),而且每一种长方体的数量都是无限的。

解题思路:用dp[i]储存顶是长方体i的最大高度,每次新加长方体时,扫之前最大高度的那个dp[i],然后将现在的高度与你求出来的dp[i]加起来生成此时的dp[i](这道题给出的长宽高可以任意组合,所以有六种)。
代码如下:
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct node
{
	int chang,kuan,gao;
}a[200];
int dp[200];
bool cmp(struct node a,struct node b)
{
	if(a.chang==b.chang)//按照题意排序 
	{
		if(a.kuan==b.kuan)
		{
			return a.gao>b.gao;
		}
		else
		{
			return a.kuan>b.kuan;
		}
	}
	else
	{
		return a.chang>b.chang;
	}
}
int main()
{
	int n;
	int Case=1;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0)
		break;
		int num=0;
		for(int i=0;i<n;i++)
		{
			int x,y,z;
			scanf("%d%d%d",&x,&y,&z);//下面将x、y、z组合 ,6种 
			a[num].chang=x;
			a[num].kuan=y;
			a[num].gao=z;
			num++;
			a[num].chang=x;
			a[num].kuan=z;
			a[num].gao=y;
			num++;
			a[num].chang=y;
			a[num].kuan=x;
			a[num].gao=z;
			num++;
			a[num].chang=y;
			a[num].kuan=z;
			a[num].gao=x;
			num++;
			a[num].chang=z;
			a[num].kuan=y;
			a[num].gao=x;
			num++;
			a[num].chang=z;
			a[num].kuan=x;
			a[num].gao=y;
			num++;
		}
		sort(a,a+num,cmp);//注意排序,长的先放 
		memset(dp,0,sizeof(dp));
		dp[0]=a[0].gao;//初始化前键 
		int ans=dp[0];//初始化ans 
		for(int i=1;i<num;i++)//i是上面的新加的小长方体 
		{
			for(int j=0;j<i;j++)//扫描i加到哪个上面得到的总高度最高 
			{
				if(a[j].chang>a[i].chang&&a[j].kuan>a[i].kuan)//新加的要小于已经放置好的 
				{
					dp[i]=max(dp[i],dp[j]);//找到之前最优的 
				}
			}
			dp[i]=dp[i]+a[i].gao;//将之前最优的加上当前高度,得到dp[i] 
			ans=max(ans,dp[i]);//更新ans 
		}
		printf("Case %d: maximum height = %d\n",Case++,ans);
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值