POJ 2785 4 Values whose Sum is 0(折半枚举)

4 Values whose Sum is 0
Time Limit: 15000MS Memory Limit: 228000K
Total Submissions: 18767 Accepted: 5571
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

 
 
6
-45 22 42 -16
-41 -27 56 30
-36 30 -75 -46
-36 53 -37 77
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

题意:有四个数列A,B,C,D。 每个数列n个数,在每个数列中都任意取出一个数。要求这四个数相加等于0,问这样的四个数组合共有多少组?

题解:直接暴力做的话O(n^4),时间复杂度很大。我们来对半分成AB和CD来考虑。从两个队列中取数就是n^2个组合。 先从A,B中取出a,b后,为了使总和为0则需要从C,D中取出c+d = -(a+b)。 因此先将C,D中取出数字的n^2种组合全部枚举出来,将这些和排序,这样就可以利用二分搜索找出满足的组合数。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 4040
int a[maxn],b[maxn],c[maxn],d[maxn],cd[maxn*maxn];
int main()
{
	int n,i,j;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<n;++i)//注意输入,竖向的 
			scanf("%d%d%d%d",&a[i],&b[i],&c[i],&d[i]);
		for(i=0;i<n;++i)
		{
			for(j=0;j<n;++j)
				cd[n*i+j]=c[i]+d[j];
		}
		sort(cd,cd+n*n);
		int ans=0;
		for(i=0;i<n;++i)
		{
			for(j=0;j<n;++j)
			{
				int k=-(a[i]+b[j]);
				ans+=upper_bound(cd,cd+n*n,k)-lower_bound(cd,cd+n*n,k);
			}//长度为n*n的有序数组中的k的个数。 
		}
		printf("%d\n",ans);
	}
	return 0;
} 





评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值