POJ 3020Antenna Placement

Antenna Placement
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7309 Accepted: 3622

Description

The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them. 
 
Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered? 

Input

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space. 

Output

For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

Sample Input

2
7 9
ooo**oooo
**oo*ooo*
o*oo**o**
ooooooooo
*******oo
o*o*oo*oo
*******oo
10 1
*
*
*
o
*
*
*
*
*
*

Sample Output

17

5

第一做,没弄清题意,以为是直接求连通块最大有几个,DFS弄了半天,后来意识到是二分匹配,关键是构造二分图,之前做过这样的一题,按着之前思路来求的。

1、给每个*编一个号

2、上下左右相连的是连通的,构造map

3、求最小路径的匹配,注意最大匹配要除以二

#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int  map[405][405],city[50][50];
int used[405],link[405];
int w,h;
int num;
int find(int x)
{
    for(int i=1;i<=num;i++)
    {
        if(map[x][i] && used[i]==0)
        {
            used[i]=1;
            if(link[i]==0 || find(link[i]))
            {
                link[i]=x;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&h,&w);
        getchar();
        memset(map,0,sizeof(map));
        memset(city,0,sizeof(city));
        memset(link,0,sizeof(link));
        char c;
        num=0;
        for(int i=1;i<=h;i++)
        {
            for(int j=1;j<=w;j++)
            {
                scanf("%c",&c);
                if(c=='*') city[i][j]=++num;
            }
            getchar();
        }
  /*      for(int i=1;i<=h;i++)
        {
            for(int j=1;j<=w;j++)
            {
                printf("%d ",city[i][j]);
            }
            printf("\n");
        }
  */

        for(int i=1;i<=h;i++)
            for(int j=1;j<=w;j++)
            {
                if(city[i][j])
                {
                    int pos=city[i][j];
                    if(i-1>0 && city[i-1][j])  map[pos][city[i-1][j]]=1;
                    if(i+1<=h && city[i+1][j]) map[pos][city[i+1][j]]=1;
                    if(j-1>0 && city[i][j-1])  map[pos][city[i][j-1]]=1;
                    if(j+1<=w && city[i][j+1]) map[pos][city[i][j+1]]=1;
                }
            }
            int all=0;
            for(int i=1;i<=num;i++)
            {
                memset(used,0,sizeof(used));
                if(find(i)) all++;
            }
            printf("%d\n",num-all/2);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值