F - Oulipo(kmp经典模板题)!!!

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
 

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
 

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3

解题思路

kmp完全匹配。。。注意next[i]=j中保存的是:b[]中以第i个数(b[i-1])结尾的前j个数(包括b[i-1])匹配b[]的前j个数。

AC代码

第一种方法:简单但不太好理解

#include<stdio.h>
#include<string.h>
char s[10010],p[1000010];
int ne[10010];
void getnext(int m)
{
	int i=0,j=-1;
	ne[0]=-1;
	while(i<m)
	{
		if(j==-1||s[i]==s[j])
		{
			i++;
			j++;
			ne[i]=j;	
		}
		else
			j=ne[j];
	}
//	for(int k=0;k<i;k++)
//	printf("%d",ne[k]);
}
int kmp(int m,int n)
{
	getnext(m);
	int i=0,j=0,sum=0;
	while(i<n)
	{
		if(j==-1||p[i]==s[j])
		{
			i++;
			j++;	
			if(j==m)
			{
				sum++;
				j=ne[j];
			}
		}
		else
			j=ne[j];

	}
	return sum;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
//		memset(ne,0,sizeof(ne));
		scanf("%s",s);
		getchar();
		scanf("%s",p);
		int m=strlen(s);
		int n=strlen(p);
		printf("%d\n",kmp(m,n));
	}
	return 0;
}

第二种方法:复杂但好理解

#include<stdio.h>
#include<iostream>
#include<string.h> 
using namespace std;
char a[10010],b[1000010];
int ne[10010];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s",a);
		getchar();
		scanf("%s",b);
		int alen=strlen(a);
		int blen=strlen(b);
		
		ne[0]=-1;
		for(int i=1,j=-1;i<alen;i++)
		{
			while(j>=0&&a[i]!=a[j+1]) j=ne[j];
			if(a[i]==a[j+1])j++;
			ne[i]=j;
		}	
		
		
		int sum=0;
		for(int i=0,j=-1;i<blen;i++)
		{
			while(j!=-1&&b[i]!=a[j+1]) 
			{
				j=ne[j];
			}
			if(b[i]==a[j+1]) 
			j++;
			if(j==alen-1)
			{
				sum++;
				j=ne[j];
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值