HDU - 3117 Fibonacci Numbers

Fibonacci Numbers

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 82 Accepted Submission(s): 47
 
Problem Description
The Fibonacci sequence is the sequence of numbers such that every element is equal to the sum of the two previous elements, except for the first two elements f0 and f1 which are respectively zero and one.

What is the numerical value of the nth Fibonacci number? 
 
Input
For each test case, a line will contain an integer i between 0 and 10 8 inclusively, for which you must compute the ith Fibonacci number fi. Fibonacci numbers get large pretty quickly, so whenever the answer has more than 8 digits, output only the first and last 4 digits of the answer, separating the two parts with an ellipsis (“...”). 

There is no special way to denote the end of the of the input, simply stop when the standard input terminates (after the EOF).
 
 
Sample Input
0
1
2
3
4
5
35
36
37
38
39
40
64
65
 
Sample Output
0
1
1
2
3
5
9227465
14930352
24157817
39088169
63245986
1023...4155
1061...7723
1716...7565
 
 
Source
IPCP 2005 Northern Preliminary for Northeast North-America
 


求斐波那契数列的后四十项的 前4位跟后4位。 前四位可以用通项公式 + log10(科学计数法) 来搞定, 后4位就可以用 构造矩阵 + 矩阵快速幂了。
斐波那契数的通项公式是:f(n)=1/sqrt(5)(((1+sqrt(5))/2)^n+((1-sqrt(5))/2)^n),对于40个后((1-sqrt(5))/2)^n可以忽略不计。
构造矩阵            | f[n]   |  * | 1   1|    = | f[n-1] |   ===== >  | f[n]    | * | 1   1 | ^ (n-2) = |  f[2]  |
                          | f[n-1]|     | 1   0|       | f[n-2] |                  | f[n-1] |    | 1    0 |               |  f[1]  |
#include <iostream>
#include <cmath>
#include <string>
#include <algorithm>
#include <string.h>
#include <map>
#include <typeinfo>
using namespace std;
const int mod = 10000;
int width;
struct Matrix {
    int a[35][35];
    void init() {
        memset(this->a, 0, sizeof(this->a));
    }
};

Matrix operator * (const Matrix& a, const Matrix& b) {
    Matrix c;
    c.init();
    for (int i = 0; i < width; ++i) {
        for (int j = 0; j < width; ++j) {
            for (int k = 0; k <width; ++k) {
                c.a[i][j] = (c.a[i][j] + a.a[i][k] * b.a[k][j]) % mod;
            }
        }
    }
    return c;
}

Matrix operator ^ (Matrix& a, int k) {
    Matrix c;
    for (int i = 0; i < width; ++i)
        for (int j = 0; j < width; ++j) {
            if (i == j)
                c.a[i][j] = 1;
            else
                c.a[i][j] = 0;
        }
    while (k) {
        if (k&1)
            c = a * c;
        k >>= 1;
        a = a * a;
    }
    return c;
}

Matrix operator + (const Matrix& a, const Matrix& b) {
    Matrix c;
    c.init();
    for (int i = 0; i < width; ++i)
        for (int j = 0; j < width; ++j)
            c.a[i][j] = (a.a[i][j] + b.a[i][j]) % mod;
    return c;
}

int main() {
    width = 2;
    int fib[45];
    fib[0] = 0;
    fib[1] = fib[2] = 1;
    for (int i = 3; i < 40; ++i)
        fib[i] = fib[i-1] + fib[i-2];
    int n;
    Matrix a;
    while (cin >> n) {
        if (n < 40) {
            cout << fib[n] << endl;
            continue;
        }
        double k = log10(1.0/sqrt(5.0)) + static_cast<double>(n * log10((1.0 + sqrt(5.0))/2.0));
        double num = k;
        num = k - static_cast<int>(num);
        a.init();
        a.a[0][0] = a.a[1][0] = a.a[0][1] = 1;
        
        Matrix temp = a ^ n;
        printf("%d...%0.4d\n",(int)(1000.0 * pow(10.0, num)), temp.a[0][1]%mod);
	//  注意补0; 
    }
}

   

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值