2016长城信息杯中国大学生程序设计竞赛中南邀请赛 xtu 1246 Heartstone

11 篇文章 0 订阅

https://i-blog.csdnimg.cn/blog_migrate/ad724a05672fa8246ecdac3691a6cc31.png

Bobo is playing Heartstone. There are n minions in the battlefield. The i -th minion has hi hit points (HP).

Bobo uses two kinds of magic. The one is Arcane Shot and the other is Frostbolt. Arcane Shot can deal twopoints damage to a minion (that is to decrease the minion's HP by two), while Frostbolt can deal three points damage. A minion is killed when its HP is less or equal to zero.

Let f(a) be the minimum number of Frostbolt(s) required to kill all minions, if no more than a Arcane Shot(s) are used. Bobo would like to find out f(0)+f(1)++f(m) modulo (109+7) .

Input

The input contains at most 30 sets. For each set:

The first line contains 2 integers n,m ( 1n105,0m105 ).

The second line contains n integers h1,h2,,hn ( 1hi104 ).

Output

For each set, an integer denotes f(0)+f(1)++f(m) modulo (109+7) .

Sample Input

3 2
1 2 3
3 2
2 2 2

Sample Output

6
6

参考了一下别人  自己写了一个 有挫的 没有写完 测试了几波输出都一样

用个优先队列维护~~~时间充足

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
#include<vector>
using namespace std;
#define ll long long
#define mod 1000000007
 
struct p
{
    int x;
    bool friend operator <(p a,p b)
    {
        return a.x%3<b.x%3 || a.x%3==b.x%3&&a.x<b.x;
    }
};
 
int main()
{
    int n,m;
    ll ans,sum;
    p t;
    while(~scanf("%d %d",&n,&m))
    {
        priority_queue<p>q;
        sum=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&t.x);
            q.push(t);
            sum+=t.x/3+(t.x%3==0?0:1);
        }
        ans=sum;printf("%lld\n",sum);
        while(m--)
        {
            if(!q.empty())
            {
                t=q.top();
                q.pop();
                sum-=t.x/3+(t.x%3==0?0:1);
                t.x-=2;
                if(t.x>0)
                {
                    sum+=t.x/3+(t.x%3==0?0:1);
                    q.push(t);
                }
                ans=(ans+sum)%mod;
            }
        }
        printf("%lld\n",ans);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值