D - EXCEL排序(sort+结构体)

D - EXCEL排序(sort+结构体)

Time Limit:5000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
Excel可以对一组纪录按任意指定列排序。现请你编写程序实现类似功能。

Input
测试输入包含若干测试用例。每个测试用例的第1行包含两个整数 N (<=100000) 和 C,其中 N 是纪录的条数,C 是指定排序的列号。以下有 N
行,每行包含一条学生纪录。每条学生纪录由学号(6位数字,同组测试中没有重复的学号)、姓名(不超过8位且不包含空格的字符串)、成绩(闭区间[0, 100]内的整数)组成,每个项目间用1个空格隔开。当读到 N=0 时,全部输入结束,相应的结果不要输出。

Output
对每个测试用例,首先输出1行“Case i:”,其中 i 是测试用例的编号(从1开始)。随后在 N 行中输出按要求排序后的结果,即:当 C=1 时,按学号递增排序;当 C=2时,按姓名的非递减字典序排序;当 C=3
时,按成绩的非递减排序。当若干学生具有相同姓名或者相同成绩时,则按他们的学号递增排序。

Sample Input
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
0 0

Sample Output
Case 1:
000001 Zoe 60
000007 James 85
000010 Amy 90
Case 2:
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Case 3:
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90


  1. 题意:
  2. 思路:
  3. 失误:
  4. 代码如下:
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<cstdio>
using namespace std;

struct st{
    char num[8];
    char name[10];
    int  sco;
}stu[111111];

bool cmp1(st a,st b)
{
    return strcmp(a.num ,b.num )<0;
}

bool cmp2(st a,st b)
{
    if(strcmp(a.name ,b.name )!=0)
     {
        return strcmp(a.name,b.name )<0;
     }
     else
     {
        return cmp1(a,b);
     }
}

bool cmp3(st a,st b)
{
    if(a.sco!=b.sco )
    {
        return a.sco <b.sco ;
    }
    else
    {
        return cmp1(a,b);
    }
}

int main()
{
    int i,j,m,n,cnt,k=0,c,l;
    while((cin>>n>>c,n))
    {
        for(i=1;i<=n;++i)
        {
            cin>>stu[i].num >>stu[i].name>>stu[i].sco ;
        }

        if(c==1)
        {
            sort(stu+1,stu+n+1,cmp1);
        }
        else  if(c==2)
        {
            sort(stu+1,stu+n+1,cmp2);
        }
        else
        {
            sort(stu+1,stu+n+1,cmp3);
        }

        ++k;
        cout<<"Case "<<k<<":"<<endl;
        for(i=1;i<=n;++i)
        {
            cout<<stu[i].num <<" "<<stu[i].name <<" "<<stu[i].sco;
            if(i!=n)
            cout<<endl; 
        }
         cout<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值