HDU 1394 Minimum Inversion Number【多数列逆序对】

 

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 18906    Accepted Submission(s): 11415

 

 

Problem Description

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

 

 

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

 

 

Output

For each case, output the minimum inversion number on a single line.

 

 

Sample Input

 

10 1 3 6 9 0 8 5 7 4 2

 

 

Sample Output

 

16

 

 

Author

CHEN, Gaoli

 

 

Source

ZOJ Monthly, January 2003

 

 

Recommend

Ignatius.L

 

 

刚开始思路错了,逆序对用树状数组只能动态求!!!

利用数组的值为0-N-1这个特点就可以用递推求出来了;

 

 

AC代码:

#include<cstdio>
#include<algorithm>

using namespace std;

struct Node{
	int val,id;
}a[10011];
int C[10011],f[5055];

bool cmp(Node a,Node b) {
	if(a.val!=b.val) return a.val>b.val;
	return a.id>b.id;
}

int Lowbit(int x) {
	return x&(-x);
}
void Add(int x,int d,int N) {
	while(x<=N) {
		C[x]+=d; x+=Lowbit(x);
	}
}
int Sum(int x) {
	int ret=0;
	while(x>0) {
		ret+=C[x]; x-=Lowbit(x);
	}
	return ret;
}

int main() {
	int N; 
	while(~scanf("%d",&N)) {
		for(int i=0;i<N;++i) {
			scanf("%d",&a[i].val); 
			a[i].id=i+1;  
		}
		sort(a,a+N,cmp);
		for(int i=0;i<N;++i) f[a[i].id-1]=i;
	    for(int i=0;i<=N;++i) C[i]=0;
	    int ans=0;
		for(int i=0;i<N;++i) {
			Add(a[i].id,1,N); 
			ans=ans+Sum(a[i].id-1); 
		}
		int pre=ans;// printf("%d\n",ans);
		for(int i=0;i<N-1;++i) {
			pre=pre-(a[f[i]].val)+(N-1-a[f[i]].val);
		//	printf("%d\n",pre);
			ans=min(ans,pre);
		}
		printf("%d\n",ans);
	}
	return 0;
} 

 

 

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值