ZOJ 3605 Find the Marble(dp)

Find the Marble

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Alice and Bob are playing a game. This game is played with several identical pots and one marble. When the game starts, Alice puts the pots in one line and puts the marble in one of the pots. After that, Bob cannot see the inside of the pots. Then Alice makes a sequence of swappings and Bob guesses which pot the marble is in. In each of the swapping, Alice chooses two different pots and swaps their positions.

Unfortunately, Alice's actions are very fast, so Bob can only catch k of m swappings and regard these k swappings as all actions Alice has performed. Now given the initial pot the marble is in, and the sequence of swappings, you are asked to calculate which pot Bob most possibly guesses. You can assume that Bob missed any of the swappings with equal possibility.

Input

There are several test cases in the input file. The first line of the input file contains an integer N (N ≈ 100), then N cases follow.

The first line of each test case contains 4 integers nmk and s(0 < s ≤ n ≤ 50, 0 ≤ k ≤ m ≤ 50), which are the number of pots, the number of swappings Alice makes, the number of swappings Bob catches and index of the initial pot the marble is in. Pots are indexed from 1 to n. Then m lines follow, each of which contains two integers ai and bi (1 ≤ aibi ≤ n), telling the two pots Alice swaps in the i-th swapping.

Outout

For each test case, output the pot that Bob most possibly guesses. If there is a tie, output the smallest one.

Sample Input
3
3 1 1 1
1 2
3 1 0 1
1 2
3 3 2 2
2 3
3 2
1 2
Sample Output
2
1

3

三维DP dp[i][j][p]表示前i个转换,看到了j个,球的位置是p

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>

using namespace std;
long long int dp[55][55][55];
int n;
int m,k,s;
int a[55][2];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d%d",&n,&m,&k,&s);
        for(int i=1;i<=m;i++)
            scanf("%d%d",&a[i][0],&a[i][1]);
        memset(dp,0,sizeof(dp));
        dp[0][0][s]=1;
        for(int i=1;i<=m;i++)
        {
            for(int j=0;j<=k;j++)
            {
                for(int p=1;p<=n;p++)
                {
                    dp[i][j][p]+=dp[i-1][j][p];
                    if(a[i][0]==p)
                        dp[i][j+1][a[i][1]]+=dp[i-1][j][p];
                    else if(a[i][1]==p)
                        dp[i][j+1][a[i][0]]+=dp[i-1][j][p];
                    else
                        dp[i][j+1][p]+=dp[i-1][j][p];
                }
            }
        }
        int ans=1;
        for(int i=2;i<=n;i++)
            if(dp[m][k][ans]<dp[m][k][i]) ans=i;
        printf("%d\n",ans);
    }
    return 0;

}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值