【Jason's_ACM_解题报告】Fill the Square

Fill the Square

In this problem, you have to draw a square using uppercase English Alphabets. 

To be more precise, you will be given a square grid with some empty blocks and others already filled for you with some letters to make your task easier. You have to insert characters in every empty cell so that the whole grid is filled with alphabets. In doing so you have to meet the following rules: 

1. Make sure no adjacent cells contain the same letter; two cells are adjacent if they share a common edge.

2. There could be many ways to fill the grid. You have to ensure you make the lexicographically smallest one. Here, two grids are checked in row major order when comparing lexicographically.


Input
The first line of input will contain an integer that will determine the number of test cases. Each case starts with an integer n (n ≤ 10), that represents the dimension of the grid. The next n lines will contain n characters each. Every cell of the grid is either a ‘.’ or a letter from [A, Z]. Here a ‘.’ represents an empty cell.


Output
For each case, first output ‘Case #:’ (# replaced by case number) and in the next n lines output the input matrix with the empty cells filled heeding the rules above.


Sample Input
2
3
...
...
...
3
...
A..
...


Sample Output
Case 1:
ABA
BAB
ABA
Case 2:
BAB
ABA
BAB


由于每个grid的四周只有4个grid因此不可能包含全部的26个大写英文字母,所以,可以放心大胆的贪心,而不必担心是否出现26个大写英文字母都不符合条件而回溯的情况,所以仅需要通过循环依次判断即可,没有必要进行DFS或者回溯。

想来,Liu可能是为了引入字典序这个经典问题吧。


附代码如下:

#include<cstdio> 
//#include<cstring>

using namespace std;

#define MAXN (10+5)

char grid[MAXN][MAXN];
int n;

bool check(int x,int y,char ch){
	if(0<x&&grid[x-1][y]==ch)return false;
	if(x<n-1&&grid[x+1][y]==ch)return false;
	if(0<y&&grid[x][y-1]==ch)return false;
	if(y<n-1&&grid[x][y+1]==ch)return false;
	return true;
}

int main(){
	int total;
	scanf("%d",&total);
	for(int k=1;k<=total;k++){
		scanf("%d",&n);
		for(int i=0;i<n;i++) scanf("%s",grid[i]);
		for(int i=0;i<n;i++){
			for(int j=0;j<n;j++){
				if(grid[i][j]=='.'){
					for(char ch='A';ch<='Z';ch++){
						if(check(i,j,ch)){
							grid[i][j]=ch;
							break;
						}
					}
				}
			}
		}
		printf("Case %d:\n",k);
		for(int i=0;i<n;i++)printf("%s\n",grid[i]);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值