【Jason's_ACM_解题报告】Maximum Product

Maximum Product

Given a sequence of integers S = {S1, S2, ..., Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.

Input
Each test case starts with 1 <= N <= 18, the number of elements in a sequence. Each element Si is an integer such that -10 <= Si <= 10. Next line will have N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).

Output
For each test case you must print the message: Case #M: The maximum product is P., where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.

Sample Input
3
2 4 -3

5
2 5 -1 2 -1

Sample Output
Case #1: The maximum product is 8.

Case #2: The maximum product is 20.

简单枚举。注意long long int存储数据。

附代码如下:
#include<cstdio>
#include<algorithm>

using namespace std;

#define MAXN (20)
#define LL long long int

int n;
int a[MAXN];

int main(){
//freopen("in.txt","r",stdin);
	int K=0;
	while(scanf("%d",&n)!=EOF){
		for(int i=0;i<n;i++)scanf("%d",&a[i]);
		LL ans=0;
		for(int i=0;i<n;i++){
			for(int j=i;j<n;j++){
				LL tmp=1;
				for(int k=i;k<=j;k++){
					tmp*=(LL)a[k];
				}
				ans=max(ans,tmp);
			}
		}
		printf("Case #%d: The maximum product is %lld.\n",++K,ans);printf("\n");
	}
//fclose(stdin);
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值