Girls' research(已完善的Manacher算法模板:输出最长回文子串)

171 篇文章 0 订阅
90 篇文章 0 订阅


Link:http://acm.hdu.edu.cn/showproblem.php?pid=3294

Girls' research

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 863    Accepted Submission(s): 335


Problem Description
One day, sailormoon girls are so delighted that they intend to research about palindromic strings. Operation contains two steps:
First step: girls will write a long string (only contains lower case) on the paper. For example, "abcde", but 'a' inside is not the real 'a', that means if we define the 'b' is the real 'a', then we can infer that 'c' is the real 'b', 'd' is the real 'c' ……, 'a' is the real 'z'. According to this, string "abcde" changes to "bcdef".
Second step: girls will find out the longest palindromic string in the given string, the length of palindromic string must be equal or more than 2.
 

Input
Input contains multiple cases.
Each case contains two parts, a character and a string, they are separated by one space, the character representing the real 'a' is and the length of the string will not exceed 200000.All input must be lowercase.
If the length of string is len, it is marked from 0 to len-1.
 

Output
Please execute the operation following the two steps.
If you find one, output the start position and end position of palindromic string in a line, next line output the real palindromic string, or output "No solution!".
If there are several answers available, please choose the string which first appears.
 

Sample Input
  
  
b babd a abcd
 

Sample Output
  
  
0 2 aza No solution!
 

Author
wangjing1111
 

Source
 


AC code:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<vector>
#include<map>
#define LL long long
#define MAXN 1000010
using namespace std;
char s1[MAXN],s2[MAXN];//s1为原字符串,s2为转换后的字符串
int p[MAXN];//p[i]表示以s2[i]为中心(包括s2[i])的回文半径,对应s1的回文长度 
char ans[MAXN];//原字符串的最长回文串 
int len; 
int l,r;//最长回文子串对应原串T中的位置:l = (i - p[i])/2; r = (i + p[i])/2 - 2;
void pre()
{
	int i,j,k;
	len=strlen(s1);
	s2[0]='$';
	s2[1]='#';
	for(i=0;i<len;i++)
	{
		s2[i*2+2]=s1[i];
		s2[i*2+3]='#';
	}
	len=len*2+2;
	s2[len]=0;
}
int Manacher()
{
	int i;
	int mx=0;
	int id;
	int ans=0;
	for(i=1;i<len;i++)
	{
		if(mx>i)
			p[i]=min(p[2*id-i],mx-i);
		else
			p[i]=1;
		for(;s2[i+p[i]]==s2[i-p[i]];p[i]++);
		if(ans<p[i])
		{
			ans=p[i];
			l = (i - p[i])/2;//最长回文子串对应原串s1中的左位置 
			r = (i + p[i])/2 - 2;//最长回文子串对应原串s1中的右位置
		}
		//ans=max(ans,p[i]);
		if(p[i]+i>mx)
		{
			mx=p[i]+i;
			id=i;
		}
	}
	return ans-1;
}
int main()
{
	 char ch,ch2;
	while(~scanf("%c %s",&ch,s1))
	{
		getchar();//注意要getchar();否则读取错误!!!
		pre();
		if(Manacher()<2)
		{
			printf("No solution!\n");
		}
		else
		{
			int cnt=0; 
			printf("%d %d\n",l,r);
			for(int i=l;i<=r;i++)
			{
				if(s1[i]-ch>=0)
				{
					ans[cnt++]='a'+s1[i]-ch;
				}
				else
				{
					ans[cnt++]='z'-(ch-s1[i])+1;
				}
			}
			ans[cnt]='\0';
			puts(ans);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值