Key Set(找规律+组合数学+快速幂)

171 篇文章 0 订阅
79 篇文章 0 订阅


Link:http://acm.hdu.edu.cn/showproblem.php?pid=5363

Key Set

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 364    Accepted Submission(s): 239


Problem Description
soda has a set  S  with  n  integers  {1,2,,n} . A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of  S  are key set.
 

Input
There are multiple test cases. The first line of input contains an integer  T   (1T105) , indicating the number of test cases. For each test case:

The first line contains an integer  n   (1n109) , the number of integers in the set.
 

Output
For each test case, output the number of key sets modulo 1000000007.
 

Sample Input
  
  
4 1 2 3 4
 

Sample Output
  
  
0 1 3 7
 

Source
 

编程思想:将集合中的数分成偶数个数和奇数个数两部分,然后利用组合数学知识和排列组合公式及其性质求解。

/*********************************************************************/

题意:给你一个具有n个元素的集合S{1,2,…,n},问集合S的非空子集中元素和为偶数的非空子集有多少个。

放入出题人的解题报告


解题思路:因为集合S中的元素是从1开始的连续的自然数,所以所有元素中奇数个数与偶数个数相同,或比偶数多一个。另外我们要知道偶数+偶数=偶数,奇数+奇数=偶数,假设现在有a个偶数,b个奇数,则


根据二项式展开公式


以及二项式展开式中奇数项系数之和等于偶数项系数之和的定理

可以得到上式

最后的结果还需减去

即空集的情况,因为题目要求非空子集

所以最终结果为


由于n很大,所以计算n次方的时候需要用到快速幂,不然会TLE


AC code:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<vector>
#include<queue>
#include<map>
#define LL long long 
#define MAXN 1000010
using namespace std;
const int INF=0x3f3f3f3f;
const double PI=acos(-1.0);
LL n,ans;
//----以下为快速幂模板-----// 
LL PowerMod(LL a, LL b, LL c)//快速求(a^b)%c 
{
	LL ans = 1;
	a = a % c;	
	while(b>0)
	{
		if(b&1)		
			ans = (ans * a) % c;
		b = b/2;
		a = (a * a) % c;
	}	
	return ans;
}
//----以上为快速幂模板-----// 
int main()
{
	//freopen("D:\in.txt","r",stdin);
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lld",&n);
		ans=PowerMod(2,n-1,1000000007)-1;
		printf("%lld\n",ans);
	}
	return 0;
}


  • 2
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值