HDU 1074 Doing Homework(状压DP)

Doing Homework

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9741    Accepted Submission(s): 4642


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.
 

Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.
 

Sample Input
  
  
2 3 Computer 3 3 English 20 1 Math 3 2 3 Computer 3 3 English 6 3 Math 6 3
 

Sample Output
  
  
2 Computer Math English 3 Computer English Math
Hint
In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.
 

Author
Ignatius.L
 

Recommend
 
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
#define maxn (1<<15)+5
const int inf=1<<30;
using namespace std;
int n,m;
int d[20],f[20];
int pre[maxn],t[maxn],dp[maxn];
char a[20][110];
void output(int x)
{
	if(!x)
		return ;
	output(x-(1<<pre[x]));
	printf("%s\n",a[pre[x]]);
}
int main ()
{
	int T,i,j;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%s %d %d",a[i],&d[i],&f[i]);
		}
		m=1<<n;
		for(i=1;i<m;i++)
		{
			dp[i]=inf;
			for(j=n-1;j>=0;j--)
			{
				int temp=1<<j;
				if((temp&i)==0)
					continue;
				int dec=t[i-temp]+f[j]-d[j];
				if(dec<0)
					dec=0;
				if(dp[i]>dp[i-temp]+dec)
				{
					dp[i]=dp[i-temp]+dec;
					t[i]=t[i-temp]+f[j];
					pre[i]=j;
				}
			}

		}
		printf("%d\n",dp[m-1]);
		output(m-1);
	}
	return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值