hdu1074Doing Homework【状态压缩】

Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.
 

Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.
 

Sample Input
  
  
2 3 Computer 3 3 English 20 1 Math 3 2 3 Computer 3 3 English 6 3 Math 6 3
 

Sample Output
  
  
2 Computer Math English 3 Computer English Math
Hint
In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.

又是一个拖了两天才写完的题,昨天下午整个状态就不好,主要就是中午没睡好==(其实是生态学睡多了),晚上这个题也没看进去T^T

题意:做作业,在规定时间内没写完拖一天扣一分,问最少扣几分,并且要求输出顺序,难为死本宝宝了,输出的还得是按字典序来的,冥思苦想百思不得其解,能想到用二进制表示状态,毕竟是状压的题,但是顺出顺序怎么搞?_(:зゝ∠)_ 别忘了,第一重循环是状态的枚举,第二重就是n个学科的枚举了呀,枚举之后替换意味着什么?意味着把相对优秀的解加入到了待输出的序列中,所以啊,每替换一个就用下标为当前状态的记录当前的学科,我们都知道状态的那个二进制每位也是学科的0/1序列,所以说当前状态中除去那个学科就是前一状态,就可以用递归表示输出了:-D 而且根据上一句话,我们可以知道,既然是要把新替换的加到最后,那么应该让新加入的是字典序大的。所以我觉得如果二进制递归输出的顺序改变,枚举学科的方向也会改变

/***********
hdu1074
2016.1.6-1.7
0MS 1964K 1162 B G++
***********/
#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int t,n,dead[20],cost[20],dp[1<<16],def[1<<16],time[1<<16];
char name[20][120];
void print(int num)
{
    if(!num) return;
    print(num-(1<<def[num]));
    printf("%s\n",name[def[num]]);
}
int main()
{
    //freopen("cin.txt","r",stdin);
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++) scanf("%s%d%d",&name[i],&dead[i],&cost[i]);
        for(int i=1;i<(1<<n);i++)
        {
            dp[i]=0x3f3f3f3f;
            for(int j=n-1;j>=0;j--)//里面有j 由i推导出之前没有j的状态
            {
                int tmp=1<<j;
                if(!(i&tmp)) continue;
                int val=time[i-tmp]+cost[j]-dead[j];
                if(val<0) val=0;
                if(dp[i]>dp[i-tmp]+val)
                {
                    dp[i]=dp[i-tmp]+val;
                    time[i]=time[i-tmp]+cost[j];
                    def[i]=j;
                }
            }
        }
        printf("%d\n",dp[(1<<n)-1]);///
        print((1<<n)-1);
    }
    return 0;
}


评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值